aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 18:55:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 18:55:48 +0000
commit8b75b598f0dce775d715df7eddb42e732c5eea7d (patch)
tree1bf784355965c9fcb23cc71f88a839c6e4c380c3 /target
parent7fbdcb07d50c4f378495991dab5dd42fa85260cf (diff)
downloadmaster-187ad058-8b75b598f0dce775d715df7eddb42e732c5eea7d.tar.gz
master-187ad058-8b75b598f0dce775d715df7eddb42e732c5eea7d.tar.bz2
master-187ad058-8b75b598f0dce775d715df7eddb42e732c5eea7d.zip
add missing piece from whiterussian image building makefile to trunk/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2250 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/image/brcm/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/image/brcm/Makefile b/target/linux/image/brcm/Makefile
index 73d236a2d5..31f941fc30 100644
--- a/target/linux/image/brcm/Makefile
+++ b/target/linux/image/brcm/Makefile
@@ -25,8 +25,13 @@ endif
ifeq ($(FS),jffs2-4MB)
TRXALIGN:=-a 0x10000
endif
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
- $(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+
+$(KDIR)/loader.tmp.gz:
+ cp $(BUILD_DIR)/loader.gz $@
+ echo -ne "\\x00" >> $@
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/loader.tmp.gz
+ $(STAGING_DIR)/bin/trx -o $@ $(KDIR)/loader.tmp.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
ifeq ($(KERNEL),2.6)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))