aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-23 18:14:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-23 18:14:14 +0000
commita89e68c01089a8db287a8bb40f4f30f3a8feb27e (patch)
tree066f5d033f55a4d2fa0a076d930cf124eaf3b1f0 /target
parent2b419ade23452e6481efa2794cbbfb5be9f5e8c6 (diff)
downloadmaster-187ad058-a89e68c01089a8db287a8bb40f4f30f3a8feb27e.tar.gz
master-187ad058-a89e68c01089a8db287a8bb40f4f30f3a8feb27e.tar.bz2
master-187ad058-a89e68c01089a8db287a8bb40f4f30f3a8feb27e.zip
do not use --owner=root or --group=root when running tar. it does not work on systems that name their root group differently
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14995 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ixp4xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 2fec61b239..53d2ef0f63 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -26,7 +26,7 @@ define Image/Build/Freecom
$(CP) $(BIN_DIR)/openwrt-$(2)-zImage $(TARGET_DIR)/zImage
rm -rf $(TARGET_DIR)/{var,jffs,rom}
$(INSTALL_DIR) $(TARGET_DIR)/var
- $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
$(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img
endef