aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-01-02 14:35:18 +0000
committerSteven Barth <steven@midlink.org>2009-01-02 14:35:18 +0000
commitc27370463eba233e0938e73b279f952027efa83c (patch)
tree96f538b08859608ddf5e0c07a10bf4aec221283d /target
parente964a25b6003d6500b563dfe343bf711a32115a3 (diff)
downloadmaster-187ad058-c27370463eba233e0938e73b279f952027efa83c.tar.gz
master-187ad058-c27370463eba233e0938e73b279f952027efa83c.tar.bz2
master-187ad058-c27370463eba233e0938e73b279f952027efa83c.zip
Use VBoxManage instead of obsolete vditool to generate VirtualBox images.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13821 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/image/Config.in2
-rw-r--r--target/linux/x86/image/Makefile6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index 6066ba44ef..ef7d0cd855 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -36,7 +36,7 @@ config X86_GRUB_BOOTOPTS
config X86_VDI_IMAGES
- bool "Build VirtualBox image files (VDI). Requires vditool"
+ bool "Build VirtualBox image files (VDI). Requires VBoxManage"
depends TARGET_x86
depends TARGET_ROOTFS_EXT2FS
depends X86_GRUB_IMAGES
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 9bd2eada6b..839646e547 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -66,7 +66,7 @@ ifeq ($(CONFIG_X86_VDI_IMAGES),y)
# left here because the image builder doesnt need these
ifeq ($(1),ext2)
rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi || true
- vditool DD $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi $(BIN_DIR)/openwrt-$(BOARD)-ext2.image
+ VBoxManage convertfromraw -format VDI $(BIN_DIR)/openwrt-$(BOARD)-ext2.image $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi
endif
endef
endif
@@ -121,8 +121,8 @@ endef
$(eval $(call BuildImage))
ifeq ($(CONFIG_X86_VDI_IMAGES),y)
- $(eval $(call RequireCommand,vditool, \
- You need vditool to generate VirtualBox images. \
+ $(eval $(call RequireCommand,VBoxManage, \
+ You need VBoxManage to generate VirtualBox images. \
))
endif