aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-01-10 23:12:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-01-10 23:12:21 +0000
commite08ba07cba7ce7b269a79dd3dee6689b2a033108 (patch)
tree0a0717b63a1ba06ef98b8f0eef27275d64c8b958 /target
parent878ec5154dfc2d80f8f902f2389970bb1878eefa (diff)
downloadmaster-187ad058-e08ba07cba7ce7b269a79dd3dee6689b2a033108.tar.gz
master-187ad058-e08ba07cba7ce7b269a79dd3dee6689b2a033108.tar.bz2
master-187ad058-e08ba07cba7ce7b269a79dd3dee6689b2a033108.zip
[x86] Use wildcards to copy grub stage files, will cover both i386-pc and i386-openwrt directory names
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13963 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index a740b0b63c..4d76639923 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -49,9 +49,9 @@ ifneq ($(HOST_OS),Darwin)
define Image/Prepare/grub
# for the image builder
$(CP) \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage1 \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage2 \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/e2fs_stage1_5 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage1 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage2 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/e2fs_stage1_5 \
$(KDIR)/
endef
else