aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-12-07 20:34:48 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-12-07 20:34:48 +0000
commitf561c967a928c83c47ada6a8fa4b3fe9e1e3c255 (patch)
tree6956835a97a8994f5b7c2d51c086a06d6baca2b1 /target
parent1977abcdce395eed91c898eebb6eed74456a415d (diff)
downloadmaster-187ad058-f561c967a928c83c47ada6a8fa4b3fe9e1e3c255.tar.gz
master-187ad058-f561c967a928c83c47ada6a8fa4b3fe9e1e3c255.tar.bz2
master-187ad058-f561c967a928c83c47ada6a8fa4b3fe9e1e3c255.zip
Add support for bcm96348gw10 (Netgear DG834GT) (#4319)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13540 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c23
-rw-r--r--target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c4
-rw-r--r--target/linux/brcm63xx/image/Makefile2
3 files changed, 27 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
index 5623d79025..42e0e97231 100644
--- a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -50,6 +50,28 @@ static struct board_info __initdata board_96348r = {
},
};
+static struct board_info __initdata board_96348gw_10 = {
+ .name = "96348GW-10",
+ .expected_cpu_id = 0x6348,
+
+ .has_enet0 = 1,
+ .has_enet1 = 1,
+ .has_pci = 1,
+
+ .enet0 = {
+ .has_phy = 1,
+ .use_internal_phy = 1,
+ },
+ .enet1 = {
+ .force_speed_100 = 1,
+ .force_duplex_full = 1,
+ },
+
+ .has_ohci0 = 1,
+ .has_pccard = 1,
+ .has_ehci0 = 1,
+};
+
static struct board_info __initdata board_96348gw_11 = {
.name = "96348GW-11",
.expected_cpu_id = 0x6348,
@@ -153,6 +175,7 @@ static const struct board_info __initdata *bcm963xx_boards[] = {
#ifdef CONFIG_BCM63XX_CPU_6348
&board_96348r,
&board_96348gw,
+ &board_96348gw_10,
&board_96348gw_11,
#endif
diff --git a/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c b/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
index 6f74945e58..6fb0ee1e08 100644
--- a/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
+++ b/target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
@@ -156,13 +156,13 @@ static int bcm963xx_probe(struct platform_device *pdev)
r = platform_get_resource(pdev, IORESOURCE_MEM, 0);
bcm963xx_map.phys = r->start;
bcm963xx_map.size = (r->end - r->start);
- bcm963xx_map.virt = ioremap(r->start, r->end - r->start);
+ bcm963xx_map.virt = ioremap(r->start, r->end - r->start + 1);
if (!bcm963xx_map.virt) {
printk(KERN_ERR PFX "Failed to ioremap\n");
return -EIO;
}
- printk(KERN_INFO PFX "0x%08x at 0x%08x\n", (r->end - r->start) + 1, r->start);
+ printk(KERN_INFO PFX "0x%08x at 0x%08x\n", bcm963xx_map.size, bcm963xx_map.phys);
simple_map_init(&bcm963xx_map);
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 516dee0e2c..ac22fee4a0 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -78,6 +78,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96358VW,6358)
# Comtrend 536
$(call Image/Build/CFE,$(1),96348GW-11,6348)
+ # DG834G
+ $(call Image/Build/CFE,$(1),96348GW-10,6348)
endef
$(eval $(call BuildImage))