aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-06 22:54:25 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-06 22:54:25 +0000
commitf8e60b69c0b6227eaccab7497f7d7f7dcc934f3e (patch)
tree903323a497e9375a70c87605e5ba3a3df98944d6 /target
parentfe8c0aaabfed69f3afdd53b4e50c06d0dc087b39 (diff)
downloadmaster-187ad058-f8e60b69c0b6227eaccab7497f7d7f7dcc934f3e.tar.gz
master-187ad058-f8e60b69c0b6227eaccab7497f7d7f7dcc934f3e.tar.bz2
master-187ad058-f8e60b69c0b6227eaccab7497f7d7f7dcc934f3e.zip
fix alsa kmod build on 2.6/mipsel (fix #7),
disable tests for other distros explicitly git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2359 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/package/alsa/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/package/alsa/Makefile b/target/linux/package/alsa/Makefile
index 6ac3156e47..128d2074ec 100644
--- a/target/linux/package/alsa/Makefile
+++ b/target/linux/package/alsa/Makefile
@@ -21,9 +21,11 @@ endif
include $(TOPDIR)/package/rules.mk
ifeq ($(LINUX_KARCH),i386)
+KERNEL_C_INCS:=
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
endif
ifeq ($(LINUX_KARCH),mips)
+KERNEL_C_INCS:= -I$(KERNEL_DIR)/include/asm-mips/mach-generic
KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
endif
@@ -31,9 +33,13 @@ $(eval $(call PKG_template,KMOD_ALSA,kmod-alsa,$(LINUX_VERSION)$(BOARD)+$(PKG_VE
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); \
+ CFLAGS="$(KERNEL_C_INCS)" \
./configure \
+ --with-build=$(KERNEL_DIR) \
--with-kernel=$(KERNEL_DIR) \
--with-cross=$(KERNEL_CROSS) \
+ --with-redhat=no \
+ --with-suse=no \
--with-oss=yes \
--with-isapnp=no \
--with-sequencer=no \