aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-12 19:08:03 +0000
committerMike Baker <mbm@openwrt.org>2006-05-12 19:08:03 +0000
commit20e4ecc021ee9aa4b799b065732f39d9daa5a2c5 (patch)
tree6c8591525420de7c8afd05b2261efe6b9071196a /toolchain/gcc
parent7b37cc4da9c275661854482bb61046d4d7a8435f (diff)
downloadmaster-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.tar.gz
master-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.tar.bz2
master-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.zip
fix BR2_ and CONFIG_ issues
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3769 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 26e17ad61e..cf60d75050 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -37,10 +37,10 @@ GCC_STRIP_HOST_BINARIES:=true
#
#############################################################
-ifeq ($(BR2_INSTALL_LIBGCJ),y)
+ifeq ($(CONFIG_INSTALL_LIBGCJ),y)
TARGET_LANGUAGES:=c,c++,java
else
-ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ifeq ($(CONFIG_INSTALL_LIBSTDCPP),y)
TARGET_LANGUAGES:=c,c++
else
TARGET_LANGUAGES:=c
@@ -71,7 +71,7 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# We can dispense with the custom spec files, as well as libfloat for the arm case.
# However, we still need a patch for arm. There's a similar patch for gcc 3.3.x
# which needs to be integrated so we can kill of libfloat for good.
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
ifeq ("$(strip $(ARCH))","arm")
$(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
endif
@@ -175,7 +175,7 @@ gcc-install: $(GCC_BUILD_DIR2)/.compiled
#
# Now for the ugly 3.3.x soft float hack...
#
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
# Make sure we have a soft float specs file for this arch
if [ ! -f ./$(GCC_VERSION)/specs-$(ARCH)-soft-float ] ; then \