aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-13 16:26:58 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-13 16:26:58 +0000
commitd16e4130df20c407adab4178e45739a7186c85c4 (patch)
treeb3ace8d720bd616131ccff15f9d4b1fa78802de7 /toolchain/gcc
parentb132cdd692739f902671b5300a156bbf1cc9e881 (diff)
downloadmaster-187ad058-d16e4130df20c407adab4178e45739a7186c85c4.tar.gz
master-187ad058-d16e4130df20c407adab4178e45739a7186c85c4.tar.bz2
master-187ad058-d16e4130df20c407adab4178e45739a7186c85c4.zip
Fix the stage2 compilation, no side effect with gcc4 (#2190)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8409 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index cd18098e9f..bae9220f0c 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -93,9 +93,7 @@ define Stage2/Configure
endef
define Stage2/Compile
- $(MAKE) -C $(BUILD_DIR2) \
- SHELL="$(BASH)" \
- all
+ export SHELL="\$(BASH)"; \$(MAKE) -C \$(BUILD_DIR2) all
endef
define Stage2/Install