aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc-ports/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
commit3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf (patch)
treee9676ee4d01368996c17caf45fd31f861e3686af /toolchain/glibc-ports/Makefile
parentec57cd80ccfc739b1d9856e7f2191d12ef568aeb (diff)
downloadmaster-187ad058-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.tar.gz
master-187ad058-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.tar.bz2
master-187ad058-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.zip
[massive] add support for alternative C libraries (currently only glibc/eglibc)
other (related) changes: - kernel headers are now installed using "make headers_install" on 2.6 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu) - build directory names now contain gcc/libc name/version - default cpu for x86 is now i486 (required to build glibc/eglibc) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/glibc-ports/Makefile')
-rw-r--r--toolchain/glibc-ports/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/toolchain/glibc-ports/Makefile b/toolchain/glibc-ports/Makefile
new file mode 100644
index 0000000000..2ddeb4e2be
--- /dev/null
+++ b/toolchain/glibc-ports/Makefile
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=glibc-ports
+PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
+
+ifeq ($(PKG_VERSION),2.3.6)
+ PKG_MD5SUM:=40dce745d34ff80401da2fdfe58f6d53
+endif
+ifeq ($(PKG_VERSION),2.6.1)
+ PKG_MD5SUM:=53d88ca624642dd267752ccce77b19d0
+endif
+ifeq ($(PKG_VERSION),2.7)
+ PKG_MD5SUM:=eaeb8527b8fa286c2d887157214f9998
+endif
+
+PKG_SOURCE_URL:=@GNU/glibc/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PATCH_DIR:=./patches/$(PKG_VERSION)
+
+STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
+BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+
+override CONFIG_AUTOREBUILD=
+
+include $(INCLUDE_DIR)/host-build.mk
+
+STAMP_BUILT:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_built
+STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_installed
+
+define Build/Prepare
+$(call Build/Prepare/Default)
+ ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Build/Install
+endef
+
+define Build/Clean
+ rm -rf \
+ $(PKG_BUILD_DIR) \
+ $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+endef
+
+$(eval $(call HostBuild))