aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc-ports/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commitb892e1fb855de59ce8e81881526ede35df1ae3fd (patch)
tree8497134d453d336d68b5dbf67d9b6b719ed2145e /toolchain/glibc-ports/Makefile
parent67c9c212e61d7ce11aa22e3ac5f7a109c134c0d1 (diff)
downloadmaster-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.gz
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.bz2
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.zip
build system refactoring in preparation for allowing packages to do host-build steps
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14610 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/glibc-ports/Makefile')
-rw-r--r--toolchain/glibc-ports/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/toolchain/glibc-ports/Makefile b/toolchain/glibc-ports/Makefile
index d9e5d0d7f5..a60b71f431 100644
--- a/toolchain/glibc-ports/Makefile
+++ b/toolchain/glibc-ports/Makefile
@@ -34,23 +34,23 @@ include $(INCLUDE_DIR)/host-build.mk
STAMP_BUILT:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_built
STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_installed
-define Build/Prepare
-$(call Build/Prepare/Default)
+define Host/Prepare
+$(call Host/Prepare/Default)
ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
endef
-define Build/Configure
+define Host/Configure
endef
-define Build/Compile
+define Host/Compile
endef
-define Build/Install
+define Host/Install
endef
-define Build/Clean
+define Host/Clean
rm -rf \
- $(PKG_BUILD_DIR) \
+ $(HOST_BUILD_DIR) \
$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
endef