aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
commit3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf (patch)
treee9676ee4d01368996c17caf45fd31f861e3686af /toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch
parentec57cd80ccfc739b1d9856e7f2191d12ef568aeb (diff)
downloadmaster-187ad058-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.tar.gz
master-187ad058-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.tar.bz2
master-187ad058-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.zip
[massive] add support for alternative C libraries (currently only glibc/eglibc)
other (related) changes: - kernel headers are now installed using "make headers_install" on 2.6 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu) - build directory names now contain gcc/libc name/version - default cpu for x86 is now i486 (required to build glibc/eglibc) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch')
-rw-r--r--toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch b/toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch
new file mode 100644
index 0000000000..2dcb793e82
--- /dev/null
+++ b/toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch
@@ -0,0 +1,12 @@
+diff -ruN glibc-2.3.6-orig/sysdeps/powerpc/powerpc32/Makefile glibc-2.3.6/sysdeps/powerpc/powerpc32/Makefile
+--- glibc-2.3.6-orig/sysdeps/powerpc/powerpc32/Makefile 2003-07-12 00:46:12.000000000 +0200
++++ glibc-2.3.6/sysdeps/powerpc/powerpc32/Makefile 2008-11-10 16:02:12.760497684 +0100
+@@ -21,7 +21,7 @@
+ ifneq ($(elf),no)
+ # The initfini generation code doesn't work in the presence of -fPIC, so
+ # we use -fpic instead which is much better.
+-CFLAGS-initfini.s = -g0 -fpic -O1
++CFLAGS-initfini.s = -fpic -O1 $(fno-unit-at-a-time)
+
+ # There is no benefit to using sdata for these objects, and the user
+ # of the library should be able to control what goes into sdata.