aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches/110-darwin_version_detect.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-15 12:03:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-15 12:03:01 +0000
commit9c49dc02eb9bc869e81ef7fc0649deddafa79633 (patch)
tree13c042de4e73382c4146ca7ce885d2fc722aa5da /toolchain/llvm/patches/110-darwin_version_detect.patch
parentfd9fbc68bb6617be37e7c779d9fd15f7428cf48c (diff)
downloadmaster-187ad058-9c49dc02eb9bc869e81ef7fc0649deddafa79633.tar.gz
master-187ad058-9c49dc02eb9bc869e81ef7fc0649deddafa79633.tar.bz2
master-187ad058-9c49dc02eb9bc869e81ef7fc0649deddafa79633.zip
toolchain: remove leftovers from old llvm-gcc experiments
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44783 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/llvm/patches/110-darwin_version_detect.patch')
-rw-r--r--toolchain/llvm/patches/110-darwin_version_detect.patch16
1 files changed, 0 insertions, 16 deletions
diff --git a/toolchain/llvm/patches/110-darwin_version_detect.patch b/toolchain/llvm/patches/110-darwin_version_detect.patch
deleted file mode 100644
index 7fd62f93ee..0000000000
--- a/toolchain/llvm/patches/110-darwin_version_detect.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Makefile.rules
-+++ b/Makefile.rules
-@@ -506,11 +506,13 @@ endif
- #--------------------------------------------------------------------
-
- ifeq ($(HOST_OS),Darwin)
-+ ifndef DARWIN_VERSION
- DARWIN_VERSION := `sw_vers -productVersion`
- # Strip a number like 10.4.7 to 10.4
- DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
- # Get "4" out of 10.4 for later pieces in the makefile.
- DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
-+ endif
-
- SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
- -dynamiclib