aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 07:26:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 07:26:34 +0000
commitfd2da7768efe5b06c8f2bea9c3d740fac648668c (patch)
tree80df33c4b4b85bad213f8a6933d5e74ff3797f42 /toolchain/uClibc/Makefile
parentf0f6a06c0ae0b8bce88182f95b0eead21ac68bb5 (diff)
downloadmaster-187ad058-fd2da7768efe5b06c8f2bea9c3d740fac648668c.tar.gz
master-187ad058-fd2da7768efe5b06c8f2bea9c3d740fac648668c.tar.bz2
master-187ad058-fd2da7768efe5b06c8f2bea9c3d740fac648668c.zip
fix pthread mklibs relinking by copying libpthread_so.a from uclibc instead of using the standard _pic variant
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18090 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 432de47220..31b996d13c 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -102,6 +102,7 @@ define Host/Compile
$(UCLIBC_MAKE) PREFIX="$(TOOLCHAIN_DIR)/" install_runtime install_dev
ln -sf ../../lib/libc.so.0 $(TOOLCHAIN_DIR)/usr/lib/libc.so
$(CP) $(HOST_BUILD_DIR)/libc/libc_so.a $(TOOLCHAIN_DIR)/usr/lib/
+ $(CP) $(HOST_BUILD_DIR)/libpthread/*/libpthread_so.a $(TOOLCHAIN_DIR)/usr/lib/
( cd $(TOOLCHAIN_DIR) ; \
for d in lib usr/lib ; do \
for f in libc.so libpthread.so libgcc_s.so ; do \