aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/patches-0.9.30+nptl
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2010-06-20 22:18:43 +0000
committerMirko Vogt <mirko@openwrt.org>2010-06-20 22:18:43 +0000
commit93567175e4d1f7fea4f055672044a787d4716051 (patch)
tree06bb7cbe4ee7fed0850d1fcd16be284c3d3d20e6 /toolchain/uClibc/patches-0.9.30+nptl
parent185a84c5944286e5b10c1f38fc2ab657607f3891 (diff)
downloadmaster-187ad058-93567175e4d1f7fea4f055672044a787d4716051.tar.gz
master-187ad058-93567175e4d1f7fea4f055672044a787d4716051.tar.bz2
master-187ad058-93567175e4d1f7fea4f055672044a787d4716051.zip
add support for uClibc version 0.9.32 based on git rev a7642511b08b0b8a4012bab67cb8aa554992df6b,
this includes support for nptl which got merged into the uClibc master branch recently git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21856 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/patches-0.9.30+nptl')
-rw-r--r--toolchain/uClibc/patches-0.9.30+nptl/110-compat_macros.patch51
-rw-r--r--toolchain/uClibc/patches-0.9.30+nptl/130-compile_fix.patch36
-rw-r--r--toolchain/uClibc/patches-0.9.30+nptl/140-math_finite.patch23
-rw-r--r--toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch33
4 files changed, 0 insertions, 143 deletions
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/110-compat_macros.patch b/toolchain/uClibc/patches-0.9.30+nptl/110-compat_macros.patch
deleted file mode 100644
index 7659e465cc..0000000000
--- a/toolchain/uClibc/patches-0.9.30+nptl/110-compat_macros.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- ./include/string.h.orig 2008-06-08 22:38:53.000000000 +0200
-+++ ./include/string.h 2009-01-02 16:09:03.000000000 +0100
-@@ -355,18 +355,40 @@
- /* Find the last occurrence of C in S (same as strrchr). */
- extern char *rindex (__const char *__s, int __c)
- __THROW __attribute_pure__ __nonnull ((1));
--# else
--# ifdef __UCLIBC_SUSV3_LEGACY_MACROS__
-+# elif defined(__UCLIBC_SUSV3_LEGACY_MACROS__) && !defined(_STRINGS_H)
- /* bcopy/bzero/bcmp/index/rindex are marked LEGACY in SuSv3.
- * They are replaced as proposed by SuSv3. Don't sync this part
- * with glibc and keep it in sync with strings.h. */
-
--# define bcopy(src,dest,n) (memmove((dest), (src), (n)), (void) 0)
--# define bzero(s,n) (memset((s), '\0', (n)), (void) 0)
--# define bcmp(s1,s2,n) memcmp((s1), (s2), (size_t)(n))
--# define index(s,c) strchr((s), (c))
--# define rindex(s,c) strrchr((s), (c))
--# endif
-+/* Copy N bytes of SRC to DEST (like memmove, but args reversed). */
-+static __inline__ void bcopy (__const void *__src, void *__dest, size_t __n)
-+{
-+ memmove(__dest, __src, __n);
-+}
-+
-+/* Set N bytes of S to 0. */
-+static __inline__ void bzero (void *__s, size_t __n)
-+{
-+ memset(__s, 0, __n);
-+}
-+
-+/* Compare N bytes of S1 and S2 (same as memcmp). */
-+static __inline__ int bcmp (__const void *__s1, __const void *__s2, size_t __n)
-+{
-+ return memcmp(__s1, __s2, __n);
-+}
-+
-+/* Find the first occurrence of C in S (same as strchr). */
-+static __inline__ char *index (__const char *__s, int __c)
-+{
-+ return strchr(__s, __c);
-+}
-+
-+/* Find the last occurrence of C in S (same as strrchr). */
-+static __inline__ char *rindex (__const char *__s, int __c)
-+{
-+ return strrchr(__s, __c);
-+}
- # endif
-
- /* Return the position of the first bit set in I, or 0 if none are set.
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/130-compile_fix.patch b/toolchain/uClibc/patches-0.9.30+nptl/130-compile_fix.patch
deleted file mode 100644
index ed3812a8ea..0000000000
--- a/toolchain/uClibc/patches-0.9.30+nptl/130-compile_fix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/librt/mq_receive.c
-+++ b/librt/mq_receive.c
-@@ -6,7 +6,8 @@
- #include <stddef.h>
- #include <sys/syscall.h>
- #include <mqueue.h>
--#warning FIXME: hard dependency on ADVANCED REALTIME feature
-+
-+#ifdef __UCLIBC_HAS_ADVANCED_REALTIME__
-
- librt_hidden_proto(mq_timedreceive)
-
-@@ -44,3 +45,5 @@ ssize_t mq_receive(mqd_t mqdes, char *ms
- {
- return mq_timedreceive(mqdes, msg_ptr, msg_len, msg_prio, NULL);
- }
-+
-+#endif /* __UCLIBC_HAS_ADVANCED_REALTIME__ */
---- a/librt/mq_send.c
-+++ b/librt/mq_send.c
-@@ -6,7 +6,8 @@
- #include <stddef.h>
- #include <sys/syscall.h>
- #include <mqueue.h>
--#warning FIXME: hard dependency on ADVANCED REALTIME feature
-+
-+#ifdef __UCLIBC_HAS_ADVANCED_REALTIME__
-
- librt_hidden_proto(mq_timedsend)
-
-@@ -43,3 +44,5 @@ int mq_send(mqd_t mqdes, const char *msg
- {
- return mq_timedsend(mqdes, msg_ptr, msg_len, msg_prio, NULL);
- }
-+
-+#endif /* __UCLIBC_HAS_ADVANCED_REALTIME__ */
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/140-math_finite.patch b/toolchain/uClibc/patches-0.9.30+nptl/140-math_finite.patch
deleted file mode 100644
index 973177235b..0000000000
--- a/toolchain/uClibc/patches-0.9.30+nptl/140-math_finite.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/include/math.h
-+++ b/include/math.h
-@@ -179,7 +179,7 @@
-
-
- /* ISO C99 defines some generic macros which work on any data type. */
--#ifdef __USE_ISOC99
-+#if defined(__USE_ISOC99) || defined(__USE_BSD)
-
- /* Get the architecture specific values describing the floating-point
- evaluation. The following symbols will get defined:
-@@ -299,6 +299,11 @@
-
- #endif /* Use ISO C99. */
-
-+/* BSD compat */
-+#define finite(x) __finite(x)
-+#define finitef(x) __finitef(x)
-+#define finitel(x) __finitel(x)
-+
- #ifdef __USE_MISC
- /* Support for various different standard error handling behaviors. */
- typedef enum
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch b/toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch
deleted file mode 100644
index bfa55583d8..0000000000
--- a/toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/libpthread/nptl/Makefile.in
-+++ b/libpthread/nptl/Makefile.in
-@@ -174,7 +174,7 @@
- CFLAGS-pthread_barrierattr_setpshared.c = -D_GNU_SOURCE
- CFLAGS-sem_open.c = -D_GNU_SOURCE
-
--CFLAGS-nptl = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 $(SSP_ALL_CFLAGS)
-+CFLAGS-nptl = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 -std=gnu99 $(SSP_ALL_CFLAGS)
-
- CFLAGS-OMIT-alloca_cutoff.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
- CFLAGS-OMIT-forward.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
---- a/libpthread/nptl/sysdeps/unix/sysv/linux/Makefile.in
-+++ b/libpthread/nptl/sysdeps/unix/sysv/linux/Makefile.in
-@@ -82,7 +82,7 @@
- CFLAGS-timer_routines.c = -I$(top_srcdir)librt -DIS_IN_librt=1
- CFLAGS-timer_settime.c = -I$(top_srcdir)librt -DIS_IN_librt=1
-
--CFLAGS-linux = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 $(SSP_ALL_CFLAGS)
-+CFLAGS-linux = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 -std=gnu99 $(SSP_ALL_CFLAGS)
- #CFLAGS:=$(CFLAGS:-O1=-O2)
-
- CFLAGS-OMIT-libc_pthread_init.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
---- a/ldso/ldso/Makefile.in
-+++ b/ldso/ldso/Makefile.in
-@@ -13,7 +13,7 @@
- CFLAGS-ldso += -fno-omit-frame-pointer
-
- CFLAGS-ldso += -I$(top_srcdir)ldso/ldso/$(TARGET_ARCH) -I$(top_srcdir)ldso/include -I$(top_srcdir)ldso/ldso
--CFLAGS-ldso += -DUCLIBC_RUNTIME_PREFIX=\"$(RUNTIME_PREFIX)\" -DUCLIBC_LDSO=\"$(UCLIBC_LDSO)\"
-+CFLAGS-ldso += -DUCLIBC_RUNTIME_PREFIX=\"$(RUNTIME_PREFIX)\" -DUCLIBC_LDSO=\"$(UCLIBC_LDSO)\" -std=gnu99
-
- ifeq ($(DODEBUG),y)
- # Not really much point in including debugging info, since gdb