aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-27 20:08:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-27 20:08:34 +0000
commit41b4d9dca281e60e63d9926aa883ab80f5f5c4ac (patch)
treea61ea1460b46ef4919551b9181a674c5f024069a /toolchain
parentce2a0c4ff821f8e493b97aa6062016f1bf7ddf51 (diff)
downloadmaster-187ad058-41b4d9dca281e60e63d9926aa883ab80f5f5c4ac.tar.gz
master-187ad058-41b4d9dca281e60e63d9926aa883ab80f5f5c4ac.tar.bz2
master-187ad058-41b4d9dca281e60e63d9926aa883ab80f5f5c4ac.zip
add gcc 4.3.3, clean up gcc version config symbols
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14226 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in4
-rw-r--r--toolchain/gcc/Config.version9
-rw-r--r--toolchain/gcc/Makefile3
3 files changed, 12 insertions, 4 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 8d91ba2c54..40042ee82b 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -30,6 +30,10 @@ choice
depends !LINUX_2_4
bool "gcc 4.3.2"
+ config GCC_VERSION_4_3_3
+ depends !LINUX_2_4
+ bool "gcc 4.3.3"
+
endchoice
config EABI_SUPPORT
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index e822445bd6..52feb5c0d4 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -5,6 +5,7 @@ config GCC_VERSION
default "4.2.4" if GCC_VERSION_4_2_4
default "4.3.1" if GCC_VERSION_4_3_1
default "4.3.2" if GCC_VERSION_4_3_2
+ default "4.3.3" if GCC_VERSION_4_3_3
default "4.1.2"
config GCC_VERSION_3
@@ -17,10 +18,9 @@ config GCC_VERSION_3_4
config GCC_VERSION_4
bool
- default y if GCC_VERSION_4_1_2
- default y if GCC_VERSION_4_2_4
- default y if GCC_VERSION_4_3_1
- default y if GCC_VERSION_4_3_2
+ default y if GCC_VERSION_4_1
+ default y if GCC_VERSION_4_2
+ default y if GCC_VERSION_4_3
config GCC_VERSION_4_1
bool
@@ -34,6 +34,7 @@ config GCC_VERSION_4_3
bool
default y if GCC_VERSION_4_3_1
default y if GCC_VERSION_4_3_2
+ default y if GCC_VERSION_4_3_3
if !TOOLCHAINOPTS
config GCC_VERSION_3_4_6
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 9a364eb8e1..0198e43641 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -41,6 +41,9 @@ endif
ifeq ($(PKG_VERSION),4.3.2)
PKG_MD5SUM:=5dfac5da961ecd5f227c3175859a486d
endif
+ifeq ($(PKG_VERSION),4.3.3)
+ PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
+endif
PATCH_DIR=./patches/$(PKG_VERSION)