aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:12:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:12:52 +0000
commitce0ba6006865f5fd67df7d359db05ec7c2de73a9 (patch)
treecff64a63c3e496a2e4d222456fe0affa2745dee9 /tools/autoconf/Makefile
parent50224b5f7c860ad6274028af57770ee8ae57ff07 (diff)
downloadmaster-187ad058-ce0ba6006865f5fd67df7d359db05ec7c2de73a9.tar.gz
master-187ad058-ce0ba6006865f5fd67df7d359db05ec7c2de73a9.tar.bz2
master-187ad058-ce0ba6006865f5fd67df7d359db05ec7c2de73a9.zip
autoconf: portability fixes
The rework of the host tools discovery caused autoconf to embed absolute paths to staging_dir/host/bin/perl into the shebang of the generated autoconfig executables. Switch to the portable "/usr/bin/env perl" and enable global warnings through "$^W" instead of the "-w" interpreter argument. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44971 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/autoconf/Makefile')
-rw-r--r--tools/autoconf/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index ec154e4647..c45855c03d 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,11 +15,11 @@ PKG_MD5SUM:=50f97f4159805e374639a73e2636f22e
include $(INCLUDE_DIR)/host-build.mk
-define Host/Configure
- $(call Host/Configure/Default,\
- --datarootdir=$(STAGING_DIR_HOST)/share \
- )
-endef
+HOST_CONFIGURE_ARGS += \
+ --datarootdir=$(STAGING_DIR_HOST)/share
+
+HOST_CONFIGURE_VARS += \
+ PERL="/usr/bin/env perl"
define Host/Compile
export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)