aboutsummaryrefslogtreecommitdiffstats
path: root/tools/missing-macros/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-21 23:50:41 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-21 23:50:41 +0000
commit0a60d4f2afd2dbf87d166db39d7cf146713c740d (patch)
treebfff2b5d2fc0e396b87b7c5e0777fe74fa1fb7a5 /tools/missing-macros/Makefile
parent8a05d522c6aba05c03f043007eea63e89e87ed72 (diff)
downloadmaster-187ad058-0a60d4f2afd2dbf87d166db39d7cf146713c740d.tar.gz
master-187ad058-0a60d4f2afd2dbf87d166db39d7cf146713c740d.tar.bz2
master-187ad058-0a60d4f2afd2dbf87d166db39d7cf146713c740d.zip
[tools] introduce missing-macros meta package, this will supply needed m4 macros which are used but not shipped by various packages in feeds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24753 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/missing-macros/Makefile')
-rw-r--r--tools/missing-macros/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/missing-macros/Makefile b/tools/missing-macros/Makefile
new file mode 100644
index 0000000000..779dbfa7f3
--- /dev/null
+++ b/tools/missing-macros/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=missing-macros
+PKG_VERSION:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+ $(INSTALL_DATA) ./src/m4/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+$(eval $(call HostBuild))