aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:12 +0000
commita690b1adea988e9f05a18af35c36fb76b91ee95b (patch)
tree3e9e21842aa5b3e54227709c4254b5449d3576f6 /tools/pkg-config/Makefile
parente3a909038d9ce69e7d582755732569355f490629 (diff)
downloadmaster-187ad058-a690b1adea988e9f05a18af35c36fb76b91ee95b.tar.gz
master-187ad058-a690b1adea988e9f05a18af35c36fb76b91ee95b.tar.bz2
master-187ad058-a690b1adea988e9f05a18af35c36fb76b91ee95b.zip
pkg-config: update to latest version, fix build on Mac OS X 10.9
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38561 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/pkg-config/Makefile')
-rw-r--r--tools/pkg-config/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index b72f3ce457..6bd53f8610 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -7,17 +7,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pkg-config
-PKG_VERSION:=0.25
+PKG_VERSION:=0.28
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
-PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
+PKG_MD5SUM:=aa3c86e67551adc3ac865160e34a2a0d
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+unexport PKG_CONFIG
+
+HOST_CONFIGURE_ARGS += --with-internal-glib
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install \