aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-07-31 17:59:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-07-31 17:59:35 +0000
commit5611c2142ce66f370652fcd15f1e54ec35c9ea98 (patch)
treebd910db24ca1bd9959a1bd99293402d1c832918b /tools/quilt
parent99477de202f2decd2e5249a8309c6797cf01173f (diff)
downloadmaster-187ad058-5611c2142ce66f370652fcd15f1e54ec35c9ea98.tar.gz
master-187ad058-5611c2142ce66f370652fcd15f1e54ec35c9ea98.tar.bz2
master-187ad058-5611c2142ce66f370652fcd15f1e54ec35c9ea98.zip
quilt: make it possible to override the path to getopt (based on patch from #9842)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27852 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index 0ed5d064b5..510d8f6fd5 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -15,9 +15,12 @@ PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
include $(INCLUDE_DIR)/host-build.mk
+GETOPT:=$(shell which getopt)
+
HOST_CONFIGURE_ARGS += \
--with-patch=$(PATCH) \
- --with-find=$(FIND)
+ --with-find=$(FIND) \
+ --with-getopt=$(GETOPT)
define Host/Configure
cd $(HOST_BUILD_DIR) && autoconf