aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-01-21 15:15:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-01-21 15:15:47 +0000
commit265bc84e98faeec69babcc14d72e7bd79f21c15e (patch)
tree6bbed7331f4081aeaa802ad939942fafe0446481 /tools
parent6798759bb1c2c0e74ed5a150713352219dc2512a (diff)
downloadmaster-187ad058-265bc84e98faeec69babcc14d72e7bd79f21c15e.tar.gz
master-187ad058-265bc84e98faeec69babcc14d72e7bd79f21c15e.tar.bz2
master-187ad058-265bc84e98faeec69babcc14d72e7bd79f21c15e.zip
[tools] only build gmp and mpfr when selecting gcc-4.3.x
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14135 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 81c69b404f..768f8786c6 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,7 +9,11 @@
curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf gmp mpfr
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf
+
+ifeq ($(CONFIG_GCC_VERSION_4_3_1)$(CONFIG_GCC_VERSION_4_3_2),y)
+$(curdir)/builddirs += gmp mpfr
+endif
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install