aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:51 +0000
commit5434e7d89f96432832664361355c0854ecda6f22 (patch)
tree50294d5d35786c5d2c7933c8125a82fa768d2ee8 /tools
parent9e9320b25383b7646c70ac32e6c90edf3ffac178 (diff)
downloadmaster-187ad058-5434e7d89f96432832664361355c0854ecda6f22.tar.gz
master-187ad058-5434e7d89f96432832664361355c0854ecda6f22.tar.bz2
master-187ad058-5434e7d89f96432832664361355c0854ecda6f22.zip
install a symlink to the correct version of find in $(STAGING_DIR_HOST)/bin
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12451 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 3cfbb8bbda..989f3f0975 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -26,8 +26,11 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
$(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
touch $@
-$(curdir)//prepare = $(STAGING_DIR)/.prepared
-$(curdir)//compile = $(STAGING_DIR)/.prepared
+$(STAGING_DIR_HOST)/bin/find:
+ [ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
+
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
# prerequisites for the individual targets
$(curdir)/ := .config prereq