aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-19 17:18:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-19 17:18:26 +0000
commit9798e24137237f83429d3827b8805c271917b82d (patch)
treecc295578920b2d0cf61a1b01e60b53d3df367aae /tools
parentd8678fa51b8374fd307f2531de76056ed32549ed (diff)
downloadmaster-187ad058-9798e24137237f83429d3827b8805c271917b82d.tar.gz
master-187ad058-9798e24137237f83429d3827b8805c271917b82d.tar.bz2
master-187ad058-9798e24137237f83429d3827b8805c271917b82d.zip
prefer gstat over stat if available (patch from #4571)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14568 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index c5a9933448..c0bbcdbeea 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -39,8 +39,9 @@ endef
$(eval $(call PrepareCommand,find,gfind find))
$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
$(eval $(call PrepareCommand,cp,gcp cp))
+$(eval $(call PrepareCommand,stat,gstat stat))
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat)
$(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
$(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)