aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-03 13:25:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-03 13:25:26 +0000
commitd9e2b41c44083498deb6674b6ff403339c7712fc (patch)
tree377ad4d422554e95a1b61a8f711a534c6cf14a76 /tools
parentca793aef55d9c728f2c3a38d822d4e3083b04eab (diff)
downloadmaster-187ad058-d9e2b41c44083498deb6674b6ff403339c7712fc.tar.gz
master-187ad058-d9e2b41c44083498deb6674b6ff403339c7712fc.tar.bz2
master-187ad058-d9e2b41c44083498deb6674b6ff403339c7712fc.zip
fix shell return status of the find symlink command
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12514 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index e15f061a4d..ecde1191ba 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -38,7 +38,9 @@ $(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
fi
$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
- [ -x "$(FIND)" -a "$(FIND)" != "$@" ] && ln -sf "$(FIND)" $@
+ if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
+ ln -sf "$(FIND)" $@; \
+ fi
$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)