aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile1
-rw-r--r--package/openwrt/libnvram/Makefile6
-rw-r--r--package/openwrt/libshared/Makefile6
3 files changed, 9 insertions, 4 deletions
diff --git a/package/Makefile b/package/Makefile
index 4fbcf83ca9..f9768de479 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -127,6 +127,7 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
compile: $(patsubst %,%-compile,$(package-y) $(package-m))
install: $(patsubst %,%-install,$(package-y))
+wificonf-compile: openwrt-compile wireless-tools-compile
arpwatch-compile: libpcap-compile
cyrus-sasl-compile: openssl-compile
dropbear-compile: zlib-compile
diff --git a/package/openwrt/libnvram/Makefile b/package/openwrt/libnvram/Makefile
index 75a1afcd6a..a5b62848ba 100644
--- a/package/openwrt/libnvram/Makefile
+++ b/package/openwrt/libnvram/Makefile
@@ -26,10 +26,12 @@ $(PKG_BUILD_DIR)/nvram: $(PKG_BUILD_DIR)/main.o $(PKG_BUILD_DIR)/libnvram.so
$(PKG_BUILD_DIR)/libnvram.so: $(LIBNVRAM_OBJS)
$(TARGET_CC) -shared -o $@ $^
+
+$(STAGING_DIR)/lib/libnvram.so: $(PKG_BUILD_DIR)/libnvram.so
+ install -m 644 $< $@
$(TARGET_DIR)/usr/lib/libnvram.so: $(PKG_BUILD_DIR)/libnvram.so
install -m 644 $< $@
- install -m 644 $< $(STAGING_DIR)/lib/libnvram.so
$(STRIP) $@
$(TARGET_DIR)/usr/sbin/nvram: $(PKG_BUILD_DIR)/nvram
@@ -37,7 +39,7 @@ $(TARGET_DIR)/usr/sbin/nvram: $(PKG_BUILD_DIR)/nvram
install -m 755 $< $@
$(STRIP) $@
-compile: $(PKG_BUILD_DIR)/libnvram.so $(PKG_BUILD_DIR)/nvram
+compile: $(PKG_BUILD_DIR)/libnvram.so $(STAGING_DIR)/lib/libnvram.so $(PKG_BUILD_DIR)/nvram
install: $(TARGET_DIR)/usr/lib/libnvram.so $(TARGET_DIR)/usr/sbin/nvram
clean:
diff --git a/package/openwrt/libshared/Makefile b/package/openwrt/libshared/Makefile
index 601dc665c5..4309c8ce66 100644
--- a/package/openwrt/libshared/Makefile
+++ b/package/openwrt/libshared/Makefile
@@ -26,12 +26,14 @@ $(PKG_BUILD_DIR):
$(PKG_BUILD_DIR)/libshared.so: $(LIBSHARED_OBJS)
$(TARGET_CC) -shared -o $@ $^
+$(STAGING_DIR)/lib/libshared.so: $(PKG_BUILD_DIR)/libshared.so
+ install -m 644 $< $@
+
$(TARGET_DIR)/usr/lib/libshared.so: $(PKG_BUILD_DIR)/libshared.so
install -m 644 $^ $@
- install -m 644 $^ $(STAGING_DIR)/lib/libshared.so
$(STRIP) $@
-compile: $(PKG_BUILD_DIR)/libshared.so
+compile: $(PKG_BUILD_DIR)/libshared.so $(STAGING_DIR)/lib/libshared.so
install: $(TARGET_DIR)/usr/lib/libshared.so
clean: