aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 553466d7bf..cd3e257a89 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -335,7 +335,9 @@ define KernelPackage/input-gpio-keys
SUBMENU:=$(OTHER_MENU)
TITLE:=GPIO key support
DEPENDS:= @GPIO_SUPPORT
- KCONFIG:=CONFIG_KEYBOARD_GPIO
+ KCONFIG:= \
+ CONFIG_KEYBOARD_GPIO \
+ CONFIG_INPUT_KEYBOARD=y
FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
$(call AddDepends/input)