aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/openmoko/Makefile2
-rw-r--r--target/linux/openmoko/image/Makefile9
2 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/openmoko/Makefile b/target/linux/openmoko/Makefile
index 22bfaea57f..e56ba1635f 100644
--- a/target/linux/openmoko/Makefile
+++ b/target/linux/openmoko/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=openmoko
BOARDNAME:=Openmoko
-FEATURES:=squashfs usb
+FEATURES:=usb
LINUX_VERSION:=2.6.24.7
diff --git a/target/linux/openmoko/image/Makefile b/target/linux/openmoko/image/Makefile
index 20f17590f3..34ca44b701 100644
--- a/target/linux/openmoko/image/Makefile
+++ b/target/linux/openmoko/image/Makefile
@@ -5,9 +5,17 @@
# See /LICENSE for more information.
#
+JFFS2_BLOCKSIZE := 128k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Image/mkfs/jffs2/sub
+ $(STAGING_DIR_HOST)/bin/mkfs.jffs2 --pad --little-endian --pagesize=0x800 --no-cleanmarkers -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(1) -d $(TARGET_DIR)
+ $(call add_jffs2_mark,$(KDIR)/root.jffs2-$(1))
+ $(call Image/Build,jffs2-$(1))
+endef
+
define Build/Clean
endef
@@ -23,6 +31,7 @@ define Image/BuildKernel
endef
define Image/Build
+ cp $(KDIR)/root.jffs2-128k $(BIN_DIR)/openwrt-$(BOARD)-rootfs
endef
$(eval $(call BuildImage))