aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ps3/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/target/linux/ps3/Makefile b/target/linux/ps3/Makefile
index 9595973342..33288d258f 100644
--- a/target/linux/ps3/Makefile
+++ b/target/linux/ps3/Makefile
@@ -9,25 +9,29 @@ include $(TOPDIR)/rules.mk
ARCH:=powerpc
BOARD:=ps3
BOARDNAME:=Sony PS3 Game Console
+MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
SUBTARGETS=petitboot
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.7
KERNEL_CC:=
include $(INCLUDE_DIR)/target.mk
define Target/Description
- Build bootloader images for the Sony PS3 Game Console
+ Build for the Sony PS3 Game Console
+
+ The OpenWRT build will create both a 1st stage PS3-Linux image
+ suitable for programming into the PS3 flash memory, and a 2nd
+ stage PS3-Linux image suitable for loading via bootloaders or
+ the kexec utility.
+
+ Enable the Petitboot package to build a PS3 bootloader.
endef
ifeq ($(CONFIG_TARGET_ps3_petitboot),y)
+define Kernel/Patch
# no patches required
-# provide facility for specific patches
-PATCH_DIR=patches-petitboot
-define Kernel/Prepare
- bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
- $(call PatchDir,$(PATCH_DIR),)
endef
endif