aboutsummaryrefslogtreecommitdiffstats
path: root/package/cups
diff options
context:
space:
mode:
Diffstat (limited to 'package/cups')
-rw-r--r--package/cups/Config.in9
-rw-r--r--package/cups/Makefile119
-rw-r--r--package/cups/files/cupsd.init4
-rw-r--r--package/cups/files/etc/cups/classes.conf7
-rw-r--r--package/cups/files/etc/cups/client.conf9
-rw-r--r--package/cups/files/etc/cups/cupsd.conf50
-rw-r--r--package/cups/files/etc/cups/printers.conf23
-rw-r--r--package/cups/ipkg/cups.conffiles4
-rw-r--r--package/cups/ipkg/cups.control5
-rw-r--r--package/cups/patches/100-makefile-targets.patch11
-rw-r--r--package/cups/patches/110-no-strip-on-install.patch12
-rw-r--r--package/cups/patches/120-documentation-url.patch20
12 files changed, 0 insertions, 273 deletions
diff --git a/package/cups/Config.in b/package/cups/Config.in
deleted file mode 100644
index 5358754b84..0000000000
--- a/package/cups/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_CUPS
- prompt "cups.............................. Common UNIX Printing System"
- tristate
- default m if CONFIG_DEVEL
- help
- A printer spooling system for devices with USB or LP support
-
- http://www.cups.org/
-
diff --git a/package/cups/Makefile b/package/cups/Makefile
deleted file mode 100644
index bb3e9d33d7..0000000000
--- a/package/cups/Makefile
+++ /dev/null
@@ -1,119 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=cups
-PKG_VERSION:=1.1.23
-PKG_RELEASE:=1
-PKG_MD5SUM:=4ce09b1dce09b6b9398af0daae9adf63
-
-PKG_SOURCE_URL:=http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/ftp.easysw.com/pub/cups/$(PKG_VERSION) \
- http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
- ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,CUPS,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --with-gnu-ld \
- --with-cups-user=root \
- --with-cups-group=root \
- --without-perl \
- --without-python \
- --without-php \
- --disable-slp \
- --disable-gnutls \
- --disable-openssl \
- --disable-cdsassl \
- --disable-ssl \
- --disable-slp \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DSTROOT="$(PKG_INSTALL_DIR)" \
- STRIP="/bin/true" \
- all install
- touch $@
-
-$(IPKG_CUPS):
- rm -rf $(IDIR_CUPS)/etc/cups
- install -d -m0755 $(IDIR_CUPS)/etc/cups
- $(CP) $(PKG_INSTALL_DIR)/etc/cups/* $(IDIR_CUPS)/etc/cups/
- rm -rf $(IDIR_CUPS)/etc/cups/certs
- ln -sf /tmp $(IDIR_CUPS)/etc/cups/certs
- install -d -m0755 $(IDIR_CUPS)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(IDIR_CUPS)/usr/bin/
- rm -f $(IDIR_CUPS)/usr/bin/cups-config
- install -d -m0755 $(IDIR_CUPS)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so.* $(IDIR_CUPS)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups $(IDIR_CUPS)/usr/lib/
- install -d -m0755 $(IDIR_CUPS)/usr/share/cups/templates
- $(CP) $(PKG_INSTALL_DIR)/usr/share/cups/templates/*.tmpl $(IDIR_CUPS)/usr/share/cups/templates/
- install -d -m0755 $(IDIR_CUPS)/usr/share/doc/cups
- $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/index.html $(IDIR_CUPS)/usr/share/doc/cups/
- $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/images $(IDIR_CUPS)/usr/share/doc/cups/
- install -d -m0755 $(IDIR_CUPS)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(IDIR_CUPS)/usr/sbin/
- # overwrite default config with our own
- $(CP) ./files/etc/cups/* $(IDIR_CUPS)/etc/cups/
- # install initscript with priority 60
- install -d -m0755 $(IDIR_CUPS)/etc/init.d
- install -m0755 ./files/cupsd.init $(IDIR_CUPS)/etc/init.d/S60cupsd
- find $(IDIR_CUPS) -name CVS | xargs rm -rf
- $(RSTRIP) $(IDIR_CUPS)
- $(IPKG_BUILD) $(IDIR_CUPS) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libcups.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/cups-config $(STAGING_DIR)/usr/bin/
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/cups $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.{a,so*} $(STAGING_DIR)/usr/lib/
-
-install-dev: $(STAGING_DIR)/usr/lib/libcups.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/bin/cups-config \
- $(STAGING_DIR)/usr/include/cups \
- $(STAGING_DIR)/usr/lib/libcups.{a,so*}
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-
diff --git a/package/cups/files/cupsd.init b/package/cups/files/cupsd.init
deleted file mode 100644
index 8e5fd63c48..0000000000
--- a/package/cups/files/cupsd.init
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-mkdir -p /tmp/cups
-mkdir -p /tmp/spool/cups/tmp
-exec /usr/sbin/cupsd
diff --git a/package/cups/files/etc/cups/classes.conf b/package/cups/files/etc/cups/classes.conf
deleted file mode 100644
index 15afda75a2..0000000000
--- a/package/cups/files/etc/cups/classes.conf
+++ /dev/null
@@ -1,7 +0,0 @@
-########################################################################
-# #
-# This is a sample class configuration file. This file is included #
-# from the main configuration file (cups.conf) and lists all of the #
-# printer classes known to the system. #
-# #
-########################################################################
diff --git a/package/cups/files/etc/cups/client.conf b/package/cups/files/etc/cups/client.conf
deleted file mode 100644
index c8d9f910ed..0000000000
--- a/package/cups/files/etc/cups/client.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-########################################################################
-# #
-# This is the CUPS client configuration file. This file is used to #
-# define client-specific parameters, such as the default server or #
-# default encryption settings. #
-# #
-########################################################################
-
-Encryption Never
diff --git a/package/cups/files/etc/cups/cupsd.conf b/package/cups/files/etc/cups/cupsd.conf
deleted file mode 100644
index e84de453b3..0000000000
--- a/package/cups/files/etc/cups/cupsd.conf
+++ /dev/null
@@ -1,50 +0,0 @@
-########################################################################
-# #
-# This is the CUPS configuration file. If you are familiar with #
-# Apache or any of the other popular web servers, we've followed the #
-# same format. Any configuration variable used here has the same #
-# semantics as the corresponding variable in Apache. If we need #
-# different functionality then a different name is used to avoid #
-# confusion... #
-# #
-########################################################################
-
-
-AccessLog syslog
-ErrorLog syslog
-LogLevel info
-PageLog syslog
-PreserveJobHistory No
-PreserveJobFiles No
-AutoPurgeJobs Yes
-MaxJobs 25
-MaxPrinterHistory 10
-#Printcap /etc/printcap
-#PrintcapFormat BSD
-RequestRoot /tmp/cups
-#RemoteRoot remroot
-User root
-Group root
-RIPCache 512k
-TempDir /tmp/cups
-Port 631
-HostNameLookups Off
-KeepAlive On
-Browsing On
-BrowseProtocols cups
-
-<Location />
-AuthType Basic
-AuthClass System
-Order Allow,Deny
-Allow From All
-</Location>
-
-<Location /admin>
-AuthType Basic
-AuthClass System
-
-Order Allow,Deny
-Allow From All
-</Location>
-
diff --git a/package/cups/files/etc/cups/printers.conf b/package/cups/files/etc/cups/printers.conf
deleted file mode 100644
index 88bba1b133..0000000000
--- a/package/cups/files/etc/cups/printers.conf
+++ /dev/null
@@ -1,23 +0,0 @@
-<DefaultPrinter USB>
-Info USB Printer
-Location
-DeviceURI usb:/dev/usb/lp0
-State Idle
-Accepting Yes
-JobSheets none none
-QuotaPeriod 0
-PageLimit 0
-KLimit 0
-</Printer>
-
-<Printer LP>
-Info Parallel Port Printer
-Location
-DeviceURI parallel:/dev/printers/0
-State Idle
-Accepting Yes
-JobSheets none none
-QuotaPeriod 0
-PageLimit 0
-KLimit 0
-</Printer>
diff --git a/package/cups/ipkg/cups.conffiles b/package/cups/ipkg/cups.conffiles
deleted file mode 100644
index bed6faa3f2..0000000000
--- a/package/cups/ipkg/cups.conffiles
+++ /dev/null
@@ -1,4 +0,0 @@
-/etc/cups/classes.conf
-/etc/cups/client.conf
-/etc/cups/cupsd.conf
-/etc/cups/printers.conf
diff --git a/package/cups/ipkg/cups.control b/package/cups/ipkg/cups.control
deleted file mode 100644
index b31f929e88..0000000000
--- a/package/cups/ipkg/cups.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: cups
-Priority: optional
-Section: net
-Depends: zlib
-Description: Common Unix Printing System
diff --git a/package/cups/patches/100-makefile-targets.patch b/package/cups/patches/100-makefile-targets.patch
deleted file mode 100644
index 590a304b12..0000000000
--- a/package/cups/patches/100-makefile-targets.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cups-1.1.23.old/Makefile 2005-01-03 20:29:44.000000000 +0100
-+++ cups-1.1.23/Makefile 2005-03-23 20:15:24.000000000 +0100
-@@ -28,7 +28,7 @@
- # Directories to make...
- #
-
--DIRS = cups backend berkeley cgi-bin filter man pdftops \
-+DIRS = cups backend berkeley cgi-bin \
- scheduler systemv
-
- #
diff --git a/package/cups/patches/110-no-strip-on-install.patch b/package/cups/patches/110-no-strip-on-install.patch
deleted file mode 100644
index 1addc7593c..0000000000
--- a/package/cups/patches/110-no-strip-on-install.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN cups-1.1.23.old/Makedefs.in cups-1.1.23/Makedefs.in
---- cups-1.1.23.old/Makedefs.in 2005-01-03 20:29:44.000000000 +0100
-+++ cups-1.1.23/Makedefs.in 2005-03-23 20:28:06.000000000 +0100
-@@ -47,7 +47,7 @@
- # Installation programs...
- #
-
--INSTALL_BIN = $(LIBTOOL) $(INSTALL) -m 755 -s
-+INSTALL_BIN = $(LIBTOOL) $(INSTALL) -m 755
- INSTALL_DATA = $(INSTALL) -m 644
- INSTALL_DIR = $(INSTALL) -d
- INSTALL_LIB = $(LIBTOOL) $(INSTALL) -m 755
diff --git a/package/cups/patches/120-documentation-url.patch b/package/cups/patches/120-documentation-url.patch
deleted file mode 100644
index 07d090c2a2..0000000000
--- a/package/cups/patches/120-documentation-url.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- cups-1.1.23/doc/index.html.orig 2005-01-03 21:13:59.000000000 +0100
-+++ cups-1.1.23/doc/index.html 2005-03-23 22:18:15.000000000 +0100
-@@ -6,7 +6,7 @@
- <AREA SHAPE="RECT" COORDS="12,10,50,20" HREF="http://www.easysw.com" ALT="Easy Software Products Home Page">
- <AREA SHAPE="RECT" COORDS="82,10,196,20" HREF="/admin" ALT="Do Administration Tasks">
- <AREA SHAPE="RECT" COORDS="216,10,280,20" HREF="/classes" ALT="Manage Printer Classes Status">
-- <AREA SHAPE="RECT" COORDS="300,10,336,20" HREF="/documentation.html" ALT="On-Line Help">
-+ <AREA SHAPE="RECT" COORDS="300,10,336,20" HREF="http://www.cups.org/documentation.php" ALT="On-Line Help">
- <AREA SHAPE="RECT" COORDS="356,10,394,20" HREF="/jobs" ALT="Manage Jobs">
- <AREA SHAPE="RECT" COORDS="414,10,476,20" HREF="/printers" ALT="Manage Printers">
- <AREA SHAPE="RECT" COORDS="496,10,568,20" HREF="http://www.cups.org" ALT="Download the Current CUPS Software">
-@@ -20,7 +20,7 @@
-
- <H1><A HREF="admin">Do Administration Tasks</A></H1>
- <H1><A HREF="classes">Manage Printer Classes</A></H1>
--<H1><A HREF="documentation.html">On-Line Help</A></H1>
-+<H1><A HREF="http://www.cups.org/documentation.php">On-Line Help</A></H1>
- <H1><A HREF="jobs">Manage Jobs</A></H1>
- <H1><A HREF="printers">Manage Printers</A></H1>
- <H1><A HREF="http://www.cups.org">Download the Current CUPS Software</A></H1>