aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/usb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/modules/usb.mk')
-rw-r--r--package/kernel/modules/usb.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 7144833158..45f69f638b 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -145,7 +145,8 @@ define KernelPackage/usb-audio
CONFIG_SND_USB_AUDIO
$(call AddDepends/usb)
$(call AddDepends/sound)
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
+# For Linux 2.6.35+
+ifneq ($(wildcard $(LINUX_DIR)/sound/usb/snd-usbmidi-lib.ko),)
FILES:= \
$(LINUX_DIR)/sound/usb/snd-usbmidi-lib.ko \
$(LINUX_DIR)/sound/usb/snd-usb-audio.ko