aboutsummaryrefslogtreecommitdiffstats
path: root/package/shfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/shfs/Makefile')
-rw-r--r--package/shfs/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/shfs/Makefile b/package/shfs/Makefile
index f4383a3f96..2562001b79 100644
--- a/package/shfs/Makefile
+++ b/package/shfs/Makefile
@@ -77,15 +77,15 @@ define Build/Compile
endef
define Package/kmod-shfs/install
- install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX) \
$(1)/lib/modules/$(LINUX_VERSION)/
endef
define Package/shfs-utils/install
- install -m0755 -d $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
- install -m0755 -d $(1)/sbin
+ $(INSTALL_DIR) $(1)/sbin
$(CP) $(PKG_INSTALL_DIR)/sbin/mount.shfs $(1)/sbin/
endef