aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ifxmips/files/cpu/mips/danube/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/uboot-ifxmips/files/cpu/mips/danube/Makefile')
-rw-r--r--package/uboot-ifxmips/files/cpu/mips/danube/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/package/uboot-ifxmips/files/cpu/mips/danube/Makefile b/package/uboot-ifxmips/files/cpu/mips/danube/Makefile
index da329b378e..6f7b5dc68a 100644
--- a/package/uboot-ifxmips/files/cpu/mips/danube/Makefile
+++ b/package/uboot-ifxmips/files/cpu/mips/danube/Makefile
@@ -1,5 +1,6 @@
+#########################################################################
#
-# (C) Copyright 2003-2006
+# (C) Copyright 2000-2006
# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
#
# See file CREDITS for list of people who contributed to this
@@ -23,18 +24,14 @@
include $(TOPDIR)/config.mk
-LIB = $(obj)lib$(CPU).a
+LIB = $(obj)lib$(SOC).a
-START = start.o
-COBJS = asc_serial.o au1x00_serial.o au1x00_eth.o au1x00_usb_ohci.o \
- cpu.o interrupts.o incaip_clock.o ifx_asc.o ifx_clock.o
-SOBJS = incaip_wdt.o cache.o
+COBJS = ifx_asc.o ifx_clock.o
-SRCS := $(START:.o=.S) $(SOBJS:.o=.S) $(COBJS:.o=.c)
+SRCS := $(SOBJS:.o=.S) $(COBJS:.o=.c)
OBJS := $(addprefix $(obj),$(SOBJS) $(COBJS))
-START := $(addprefix $(obj),$(START))
-all: $(obj).depend $(START) $(LIB)
+all: $(obj).depend $(LIB)
$(LIB): $(OBJS)
$(AR) $(ARFLAGS) $@ $(OBJS)