aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/patches/000-build-infos.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/uboot-lantiq/patches/000-build-infos.patch')
-rw-r--r--package/uboot-lantiq/patches/000-build-infos.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/package/uboot-lantiq/patches/000-build-infos.patch b/package/uboot-lantiq/patches/000-build-infos.patch
deleted file mode 100644
index bd185d9b5a..0000000000
--- a/package/uboot-lantiq/patches/000-build-infos.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Add output like in linux kernel for current compiled file
-Used normaly in combination with make option -s
-
-Like in following example:
-
-$ make -s V=1
-[CC] tools/img2srec.c
-[CC] tools/bmp_logo.c
-[CC] examples/hello_world.c
-
---- a/config.mk
-+++ b/config.mk
-@@ -234,17 +234,47 @@ export TEXT_BASE PLATFORM_CPPFLAGS PLATF
-
- #########################################################################
-
-+ifndef KBUILD_VERBOSE
-+ KBUILD_VERBOSE:=0
-+endif
-+ifeq ("$(origin V)", "command line")
-+ KBUILD_VERBOSE:=$(V)
-+endif
-+ifeq (,$(findstring s,$(MAKEFLAGS)))
-+ KBUILD_VERBOSE:=0
-+endif
-+
-+ifneq ($(KBUILD_VERBOSE),0)
-+ define MESSAGE
-+ @printf " %s %s/%s\n" $(1) $(2) $(3)
-+ endef
-+else
-+ define MESSAGE
-+ endef
-+endif
-+
- # Allow boards to use custom optimize flags on a per dir/file basis
- BCURDIR := $(notdir $(CURDIR))
-+
- $(obj)%.s: %.S
-+ $(call MESSAGE, [CPP],$(subst $(SRCTREE)/,,$(CURDIR)),$<)
-+ #echo $(CPP) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $<
- $(CPP) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $<
- $(obj)%.o: %.S
-+ $(call MESSAGE, [AS], $(subst $(SRCTREE)/,,$(CURDIR)),$<)
-+ #echo $(CC) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $< -c
- $(CC) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $< -c
- $(obj)%.o: %.c
-+ $(call MESSAGE, [CC], $(subst $(SRCTREE)/,,$(CURDIR)),$<)
-+ #echo $(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
- $(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
- $(obj)%.i: %.c
-+ $(call MESSAGE, [CPP],$(subst $(SRCTREE)/,,$(CURDIR)),$<)
-+ #echo $(CPP) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
- $(CPP) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
- $(obj)%.s: %.c
-+ $(call MESSAGE, [CC], $(subst $(SRCTREE)/,,$(CURDIR)),$<)
-+ #echo $(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c -S
- $(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c -S
-
- #########################################################################