aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.26/001-adm5120.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/patches-2.6.26/001-adm5120.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.26/001-adm5120.patch57
1 files changed, 0 insertions, 57 deletions
diff --git a/target/linux/adm5120/patches-2.6.26/001-adm5120.patch b/target/linux/adm5120/patches-2.6.26/001-adm5120.patch
deleted file mode 100644
index ffebf85b97..0000000000
--- a/target/linux/adm5120/patches-2.6.26/001-adm5120.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -18,6 +18,22 @@ choice
- prompt "System type"
- default SGI_IP22
-
-+config ADM5120
-+ bool "Infineon/ADMtek ADM5120 SoC based machines"
-+ select CEVT_R4K
-+ select CSRC_R4K
-+ select SYS_HAS_CPU_MIPS32_R1
-+ select SYS_HAS_EARLY_PRINTK
-+ select DMA_NONCOHERENT
-+ select IRQ_CPU
-+ select SYS_SUPPORTS_LITTLE_ENDIAN
-+ select SYS_SUPPORTS_BIG_ENDIAN
-+ select SYS_SUPPORTS_32BIT_KERNEL
-+ select GENERIC_GPIO
-+ select HAVE_GPIO_LIB
-+ select SWAP_IO_SPACE if CPU_BIG_ENDIAN
-+ select MIPS_MACHINE
-+
- config MACH_ALCHEMY
- bool "Alchemy processor based machines"
-
-@@ -687,6 +702,7 @@ config WR_PPMC
-
- endchoice
-
-+source "arch/mips/adm5120/Kconfig"
- source "arch/mips/au1000/Kconfig"
- source "arch/mips/basler/excite/Kconfig"
- source "arch/mips/jazz/Kconfig"
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -174,6 +174,21 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/
- load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
-
- #
-+# Infineon/ADMtek ADM5120
-+#
-+libs-$(CONFIG_ADM5120) += arch/mips/adm5120/prom/
-+core-$(CONFIG_ADM5120) += arch/mips/adm5120/common/
-+core-$(CONFIG_ADM5120_OEM_CELLVISION) += arch/mips/adm5120/cellvision/
-+core-$(CONFIG_ADM5120_OEM_COMPEX) += arch/mips/adm5120/compex/
-+core-$(CONFIG_ADM5120_OEM_EDIMAX) += arch/mips/adm5120/edimax/
-+core-$(CONFIG_ADM5120_OEM_INFINEON) += arch/mips/adm5120/infineon/
-+core-$(CONFIG_ADM5120_OEM_MIKROTIK) += arch/mips/adm5120/mikrotik/
-+core-$(CONFIG_ADM5120_OEM_MOTOROLA) += arch/mips/adm5120/motorola/
-+core-$(CONFIG_ADM5120_OEM_ZYXEL) += arch/mips/adm5120/zyxel/
-+cflags-$(CONFIG_ADM5120) += -Iinclude/asm-mips/mach-adm5120
-+load-$(CONFIG_ADM5120) += 0xffffffff80001000
-+
-+#
- # Common Alchemy Au1x00 stuff
- #
- core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/