aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile48
1 files changed, 21 insertions, 27 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 8cf83a4563..f594c5b056 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -20,8 +20,8 @@ endef
define Build/boot-img
rm -f $@.boot
mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+ mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
mcopy -i $@.boot $(KDIR)/bootcode.bin ::
- mcopy -i $@.boot $(KDIR)/COPYING.linux ::
mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
mcopy -i $@.boot $(KDIR)/start.elf ::
mcopy -i $@.boot $(KDIR)/start_cd.elf ::
@@ -32,7 +32,7 @@ define Build/boot-img
mcopy -i $@.boot $(word 1,$^) ::kernel.img
$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
mmd -i $@.boot ::/overlays
- mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
+ mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
endef
@@ -42,45 +42,39 @@ define Build/sdcard-img
$(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
endef
-### Device macros ###
+### Devices ###
define Device/Default
FILESYSTEMS := ext4
- PROFILES = Default $$(DEVICE_PROFILE)
KERNEL := kernel-bin | kernel-img
IMAGES := sdcard.img
IMAGE/sdcard.img := boot-img | sdcard-img
- DEVICE_PROFILE :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_DTS
-# $(1) = profile
-# $(2) = image name
-# $(3) = dts
-define bcm27xx
- define Device/$(2)
- DEVICE_PROFILE := $(1)
- DEVICE_DTS := $(3)
- endef
- TARGET_DEVICES += $(2)
+define Device/rpi
+ DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero
+ DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
endef
-
-### BCM2708/BCM2835 ###
ifeq ($(SUBTARGET),bcm2708)
- # Raspberry Pi Models B/B+/CM
- $(eval $(call bcm27xx,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
+ TARGET_DEVICES += rpi
endif
-### BCM2709/BCM2836 ###
-ifeq ($(SUBTARGET),bcm2709)
- # Raspberry Pi 2 Model B
- $(eval $(call bcm27xx,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+define Device/rpi-2
+ DEVICE_TITLE := Raspberry Pi 2 B
+ DEVICE_DTS := bcm2709-rpi-2-b
+endef
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi-2
endif
-### BCM2710/BCM2837 ###
-ifeq ($(SUBTARGET),bcm2710)
- # Raspberry Pi 3 Model B
- $(eval $(call bcm27xx,RaspberryPi_3,rpi-3,bcm2710-rpi-3-b))
+define Device/rpi-3
+ DEVICE_TITLE := Raspberry Pi 3 B
+ DEVICE_DTS := bcm2710-rpi-3-b
+ DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
+endef
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi-3
endif
$(eval $(call BuildImage))