aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/611-netfilter_condition.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.4/patches/611-netfilter_condition.patch')
-rw-r--r--target/linux/generic-2.4/patches/611-netfilter_condition.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic-2.4/patches/611-netfilter_condition.patch b/target/linux/generic-2.4/patches/611-netfilter_condition.patch
index 873e60e372..511d32a06f 100644
--- a/target/linux/generic-2.4/patches/611-netfilter_condition.patch
+++ b/target/linux/generic-2.4/patches/611-netfilter_condition.patch
@@ -15,7 +15,7 @@
conntrack match support
CONFIG_IP_NF_MATCH_CONNTRACK
This is a general conntrack match module, a superset of the state match.
-@@ -3365,6 +3373,14 @@ CONFIG_IP6_NF_MATCH_MARK
+@@ -3296,6 +3304,14 @@ CONFIG_IP6_NF_MATCH_MARK
If you want to compile it as a module, say M here and read
<file:Documentation/modules.txt>. If unsure, say `N'.
@@ -60,7 +60,7 @@
+#endif
--- a/net/ipv4/netfilter/Config.in
+++ b/net/ipv4/netfilter/Config.in
-@@ -41,6 +41,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
+@@ -27,6 +27,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
dep_tristate ' netfilter MARK match support' CONFIG_IP_NF_MATCH_MARK $CONFIG_IP_NF_IPTABLES
dep_tristate ' Multiple port match support' CONFIG_IP_NF_MATCH_MULTIPORT $CONFIG_IP_NF_IPTABLES
dep_tristate ' TOS match support' CONFIG_IP_NF_MATCH_TOS $CONFIG_IP_NF_IPTABLES
@@ -70,7 +70,7 @@
dep_tristate ' peer to peer traffic match support' CONFIG_IP_NF_MATCH_IPP2P $CONFIG_IP_NF_IPTABLES
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -85,6 +85,7 @@ obj-$(CONFIG_IP_NF_MATCH_PKTTYPE) += ipt
+@@ -73,6 +73,7 @@ obj-$(CONFIG_IP_NF_MATCH_PKTTYPE) += ipt
obj-$(CONFIG_IP_NF_MATCH_MULTIPORT) += ipt_multiport.o
obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_owner.o
obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o