aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image/aruba/lzma-loader/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/image/aruba/lzma-loader/src/Makefile')
-rw-r--r--target/linux/image/aruba/lzma-loader/src/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/image/aruba/lzma-loader/src/Makefile b/target/linux/image/aruba/lzma-loader/src/Makefile
new file mode 100644
index 0000000000..3d0a58586d
--- /dev/null
+++ b/target/linux/image/aruba/lzma-loader/src/Makefile
@@ -0,0 +1,38 @@
+LOADADDR = 0x81000000
+RAMSIZE = 0x00100000 # 1MB
+
+CROSS_COMPILE = mips-linux-
+
+.S.s:
+ $(CPP) $(CFLAGS) $< -o $*.s
+.S.o:
+ $(CC) $(CFLAGS) -c $< -o $*.o
+.c.o:
+ $(CC) $(CFLAGS) -c $< -o $*.o
+
+CC = $(CROSS_COMPILE)gcc
+LD = $(CROSS_COMPILE)ld
+OBJCOPY = $(CROSS_COMPILE)objcopy
+OBJDUMP = $(CROSS_COMPILE)objdump
+
+CFLAGS = -fno-builtin -Os -G 0 -mno-abicalls -fno-pic -Wall -DRAMSIZE=${RAMSIZE} -D_LZMA_IN_CB
+# CFLAGS = -fno-builtin -Os -G 0 -mno-abicalls -fno-pic -Wall -DRAMSIZE=${RAMSIZE}
+
+O_FORMAT = $(shell $(OBJDUMP) -i | head -2 | grep elf32)
+
+# Drop some uninteresting sections in the kernel.
+# This is only relevant for ELF kernels but doesn't hurt a.out
+drop-sections = .reginfo .mdebug .comment
+strip-flags = $(addprefix --remove-section=,$(drop-sections))
+
+
+all : lzma.elf
+
+kernel.o: vmlinux.lzma
+ $(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
+
+lzma.elf: start.o decompress.o LzmaDecode.o kernel.o
+ $(LD) -s -Tlzma.lds -o $@ $^
+
+clean:
+ rm -f *.o lzma.elf