aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/patches-0.9.8
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/musl/patches-0.9.8')
-rw-r--r--toolchain/musl/patches-0.9.8/001-bsd_ether_h.patch219
-rw-r--r--toolchain/musl/patches-0.9.8/002-no_mips_fpu.patch49
-rw-r--r--toolchain/musl/patches-0.9.8/003-in_h_are_4_equal_parenthesis.patch12
-rw-r--r--toolchain/musl/patches-0.9.8/004-wchar_include.patch60
-rw-r--r--toolchain/musl/patches-0.9.8/005-install_portability.patch27
5 files changed, 0 insertions, 367 deletions
diff --git a/toolchain/musl/patches-0.9.8/001-bsd_ether_h.patch b/toolchain/musl/patches-0.9.8/001-bsd_ether_h.patch
deleted file mode 100644
index be3a0217ac..0000000000
--- a/toolchain/musl/patches-0.9.8/001-bsd_ether_h.patch
+++ /dev/null
@@ -1,219 +0,0 @@
-Date: Sat, 20 Oct 2012 22:15:44 +0200
-From: Abdoulaye Walsimou Gaye <awg@...toolkit.org>
-To: musl@...ts.openwall.com
-Cc: Abdoulaye Walsimou Gaye <awg@...toolkit.org>
-Subject: [PATCH 3/4] Import BSD functions defined in <netinet/ether.h> from NetBSD
-
-Signed-off-by: Abdoulaye Walsimou Gaye <awg@...toolkit.org>
----
- include/netinet/ether.h | 14 ++++
- src/network/ethers.c | 180 +++++++++++++++++++++++++++++++++++++++++++++++
- 2 files changed, 194 insertions(+)
- create mode 100644 include/netinet/ether.h
- create mode 100644 src/network/ethers.c
-
-diff --git a/include/netinet/ether.h b/include/netinet/ether.h
-new file mode 100644
-index 0000000..44c614e
---- /dev/null
-+++ b/include/netinet/ether.h
-@@ -0,0 +1,10 @@
-+#ifndef _NETINET_ETHER_H
-+#define _NETINET_ETHER_H
-+
-+char *ether_ntoa(const struct ether_addr *);
-+struct ether_addr *ether_aton(const char *);
-+int ether_ntohost(char *, const struct ether_addr *);
-+int ether_hostton(const char *, struct ether_addr *);
-+int ether_line(const char *, struct ether_addr *, char *);
-+
-+#endif /* !_NETINET_ETHER_H */
-diff --git a/src/network/ethers.c b/src/network/ethers.c
-new file mode 100644
-index 0000000..8014581
---- /dev/null
-+++ b/src/network/ethers.c
-@@ -0,0 +1,180 @@
-+/* Origin NetBSD: src/lib/libc/net/ethers.c */
-+
-+/*
-+ * ethers(3N) a la Sun.
-+ *
-+ * Written by Roland McGrath <roland@...b.com> 10/14/93.
-+ * Public domain.
-+ *
-+ * port for musl by Abdoulaye Walsimou GAYE <awg@...toolkit.org> 2012/10/15
-+ */
-+
-+#define _BSD_SOURCE
-+#include <net/ethernet.h>
-+#include <netinet/ether.h>
-+
-+#include <sys/param.h>
-+#include <assert.h>
-+#include <errno.h>
-+#include <paths.h>
-+#include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
-+
-+#ifndef _PATH_ETHERS
-+#define _PATH_ETHERS "/etc/ethers"
-+#endif
-+
-+/*
-+ * ether_ntoa():
-+ * This function converts this structure into an ASCII string of the form
-+ * ``xx:xx:xx:xx:xx:xx'', consisting of 6 hexadecimal numbers separated
-+ * by colons. It returns a pointer to a static buffer that is reused for
-+ * each call.
-+ */
-+char *ether_ntoa(const struct ether_addr *e)
-+{
-+ static char a[18];
-+
-+ assert(e != NULL);
-+
-+ (void) snprintf(a, sizeof a, "%02x:%02x:%02x:%02x:%02x:%02x",
-+ e->ether_addr_octet[0], e->ether_addr_octet[1],
-+ e->ether_addr_octet[2], e->ether_addr_octet[3],
-+ e->ether_addr_octet[4], e->ether_addr_octet[5]);
-+ return a;
-+}
-+
-+/*
-+ * ether_aton():
-+ * This function converts an ASCII string of the same form and to a structure
-+ * containing the 6 octets of the address. It returns a pointer to a
-+ * static structure that is reused for each call.
-+ */
-+struct ether_addr *ether_aton(const char *s)
-+{
-+ static struct ether_addr n;
-+ unsigned int i[6];
-+
-+ assert(s != NULL);
-+
-+ if (sscanf(s, " %x:%x:%x:%x:%x:%x ", &i[0], &i[1],
-+ &i[2], &i[3], &i[4], &i[5]) == 6) {
-+ n.ether_addr_octet[0] = (unsigned char)i[0];
-+ n.ether_addr_octet[1] = (unsigned char)i[1];
-+ n.ether_addr_octet[2] = (unsigned char)i[2];
-+ n.ether_addr_octet[3] = (unsigned char)i[3];
-+ n.ether_addr_octet[4] = (unsigned char)i[4];
-+ n.ether_addr_octet[5] = (unsigned char)i[5];
-+ return &n;
-+ }
-+ return NULL;
-+}
-+
-+/*
-+ * ether_ntohost():
-+ * This function interrogates the data base mapping host names to Ethernet
-+ * addresses, /etc/ethers.
-+ * It looks up the given Ethernet address and writes the associated host name
-+ * into the character buffer passed.
-+ * It returns zero if it finds the requested host name and -1 if not.
-+ */
-+int ether_ntohost(char *hostname, const struct ether_addr *e)
-+{
-+ FILE *f;
-+ char *p;
-+ size_t len;
-+ struct ether_addr try;
-+
-+ assert(hostname != NULL);
-+ assert(e != NULL);
-+
-+ f = fopen(_PATH_ETHERS, "r");
-+ if (f == NULL)
-+ return -1;
-+ while ((p = fgetln(f, &len)) != NULL) {
-+ if (p[len - 1] != '\n')
-+ continue; /* skip lines w/o \n */
-+ p[--len] = '\0';
-+ if (ether_line(p, &try, hostname) == 0 &&
-+ memcmp(&try, e, sizeof try) == 0) {
-+ (void)fclose(f);
-+ return 0;
-+ }
-+ }
-+ (void)fclose(f);
-+ errno = ENOENT;
-+ return -1;
-+}
-+
-+/*
-+ * ether_hostton():
-+ * This function interrogates the data base mapping host names to Ethernet
-+ * addresses, /etc/ethers.
-+ * It looks up the given host name and writes the associated Ethernet address
-+ * into the structure passed.
-+ * It returns zero if it finds the requested address and -1 if not.
-+ */
-+int ether_hostton(const char *hostname, struct ether_addr *e)
-+{
-+ FILE *f;
-+ char *p;
-+ size_t len;
-+ char try[MAXHOSTNAMELEN + 1];
-+
-+ assert(hostname != NULL);
-+ assert(e != NULL);
-+
-+ f = fopen(_PATH_ETHERS, "r");
-+ if (f==NULL)
-+ return -1;
-+
-+ while ((p = fgetln(f, &len)) != NULL) {
-+ if (p[len - 1] != '\n')
-+ continue; /* skip lines w/o \n */
-+ p[--len] = '\0';
-+ if (ether_line(p, e, try) == 0 && strcmp(hostname, try) == 0) {
-+ (void)fclose(f);
-+ return 0;
-+ }
-+ }
-+ (void)fclose(f);
-+ errno = ENOENT;
-+ return -1;
-+}
-+
-+/*
-+ * ether_line():
-+ * This function parses a line from the /etc/ethers file and fills in the passed
-+ * ``struct ether_addr'' and character buffer with the Ethernet address and host
-+ * name on the line.
-+ * It returns zero if the line was successfully parsed and -1 if not.
-+ */
-+int ether_line(const char *l, struct ether_addr *e, char *hostname)
-+{
-+ unsigned int i[6];
-+
-+#define S2(arg) #arg
-+#define S1(arg) S2(arg)
-+ static const char fmt[] = " %x:%x:%x:%x:%x:%x"
-+ " %" S1(MAXHOSTNAMELEN) "s\n";
-+#undef S2
-+#undef S1
-+
-+ assert(l != NULL);
-+ assert(e != NULL);
-+ assert(hostname != NULL);
-+
-+ if (sscanf(l, fmt,
-+ &i[0], &i[1], &i[2], &i[3], &i[4], &i[5], hostname) == 7) {
-+ e->ether_addr_octet[0] = (unsigned char)i[0];
-+ e->ether_addr_octet[1] = (unsigned char)i[1];
-+ e->ether_addr_octet[2] = (unsigned char)i[2];
-+ e->ether_addr_octet[3] = (unsigned char)i[3];
-+ e->ether_addr_octet[4] = (unsigned char)i[4];
-+ e->ether_addr_octet[5] = (unsigned char)i[5];
-+ return 0;
-+ }
-+ errno = EINVAL;
-+ return -1;
-+}
---
-1.7.9.5
-
diff --git a/toolchain/musl/patches-0.9.8/002-no_mips_fpu.patch b/toolchain/musl/patches-0.9.8/002-no_mips_fpu.patch
deleted file mode 100644
index 92af325af8..0000000000
--- a/toolchain/musl/patches-0.9.8/002-no_mips_fpu.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -urN musl-0.9.7/src/setjmp/mips/longjmp.s musl-0.9.7.new/src/setjmp/mips/longjmp.s
---- musl-0.9.7/src/setjmp/mips/longjmp.s 2012-11-23 17:03:07.000000000 +0100
-+++ musl-0.9.7.new/src/setjmp/mips/longjmp.s 2012-11-23 21:52:57.353668480 +0100
-@@ -10,21 +10,7 @@
- bne $2, $0, 1f
- nop
- addu $2, $2, 1
--1: lw $8, 48($4)
-- ctc1 $8, $31
-- lwc1 $20, 56($4)
-- lwc1 $21, 60($4)
-- lwc1 $22, 64($4)
-- lwc1 $23, 68($4)
-- lwc1 $24, 72($4)
-- lwc1 $25, 76($4)
-- lwc1 $26, 80($4)
-- lwc1 $27, 84($4)
-- lwc1 $28, 88($4)
-- lwc1 $29, 92($4)
-- lwc1 $30, 96($4)
-- lwc1 $31, 100($4)
-- lw $ra, 0($4)
-+1: lw $ra, 0($4)
- lw $sp, 4($4)
- lw $16, 8($4)
- lw $17, 12($4)
-diff -urN musl-0.9.7/src/setjmp/mips/setjmp.s musl-0.9.7.new/src/setjmp/mips/setjmp.s
---- musl-0.9.7/src/setjmp/mips/setjmp.s 2012-11-23 17:03:07.000000000 +0100
-+++ musl-0.9.7.new/src/setjmp/mips/setjmp.s 2012-11-23 21:52:33.713667876 +0100
-@@ -21,19 +21,5 @@
- sw $23, 36($4)
- sw $30, 40($4)
- sw $28, 44($4)
-- cfc1 $8, $31
-- sw $8, 48($4)
-- swc1 $20, 56($4)
-- swc1 $21, 60($4)
-- swc1 $22, 64($4)
-- swc1 $23, 68($4)
-- swc1 $24, 72($4)
-- swc1 $25, 76($4)
-- swc1 $26, 80($4)
-- swc1 $27, 84($4)
-- swc1 $28, 88($4)
-- swc1 $29, 92($4)
-- swc1 $30, 96($4)
-- swc1 $31, 100($4)
- jr $ra
- li $2, 0
diff --git a/toolchain/musl/patches-0.9.8/003-in_h_are_4_equal_parenthesis.patch b/toolchain/musl/patches-0.9.8/003-in_h_are_4_equal_parenthesis.patch
deleted file mode 100644
index 41aaf5d3da..0000000000
--- a/toolchain/musl/patches-0.9.8/003-in_h_are_4_equal_parenthesis.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN musl-0.9.8/include/netinet/in.h musl-0.9.8.new/include/netinet/in.h
---- musl-0.9.8/include/netinet/in.h 2013-01-25 14:14:07.000000000 +0100
-+++ musl-0.9.8.new/include/netinet/in.h 2013-01-29 21:43:46.843051396 +0100
-@@ -141,7 +141,7 @@
- (IN6_IS_ADDR_MULTICAST(a) && ((((uint8_t *) (a))[1] & 0xf) == 0xe))
-
- #define __ARE_4_EQUAL(a,b) \
-- (!( 0[a]-0[b] | 1[a]-1[b] | 2[a]-2[b] | 3[a]-3[b] ))
-+ (!( (0[a]-0[b]) | (1[a]-1[b]) | (2[a]-2[b]) | (3[a]-3[b]) ))
- #define IN6_ARE_ADDR_EQUAL(a,b) \
- __ARE_4_EQUAL((const uint32_t *)(a), (const uint32_t *)(b))
-
diff --git a/toolchain/musl/patches-0.9.8/004-wchar_include.patch b/toolchain/musl/patches-0.9.8/004-wchar_include.patch
deleted file mode 100644
index 2f36ae5805..0000000000
--- a/toolchain/musl/patches-0.9.8/004-wchar_include.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/arch/arm/bits/alltypes.h.sh
-+++ b/arch/arm/bits/alltypes.h.sh
-@@ -21,6 +21,7 @@ TYPEDEF int ssize_t;
- TYPEDEF int ptrdiff_t;
-
- TYPEDEF __builtin_va_list va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF unsigned wchar_t;
---- a/arch/i386/bits/alltypes.h.sh
-+++ b/arch/i386/bits/alltypes.h.sh
-@@ -25,6 +25,7 @@ TYPEDEF __builtin_va_list va_list;
- #else
- TYPEDEF struct __va_list * va_list;
- #endif
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- #ifdef __WCHAR_TYPE__
---- a/arch/microblaze/bits/alltypes.h.sh
-+++ b/arch/microblaze/bits/alltypes.h.sh
-@@ -21,6 +21,7 @@ TYPEDEF int ssize_t;
- TYPEDEF int ptrdiff_t;
-
- TYPEDEF __builtin_va_list va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF int wchar_t;
---- a/arch/mips/bits/alltypes.h.sh
-+++ b/arch/mips/bits/alltypes.h.sh
-@@ -21,6 +21,7 @@ TYPEDEF int ssize_t;
- TYPEDEF int ptrdiff_t;
-
- TYPEDEF __builtin_va_list va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF int wchar_t;
---- a/arch/powerpc/bits/alltypes.h.sh
-+++ b/arch/powerpc/bits/alltypes.h.sh
-@@ -21,6 +21,7 @@ TYPEDEF int ssize_t;
- TYPEDEF int ptrdiff_t;
-
- TYPEDEF __builtin_va_list va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF long wchar_t;
---- a/arch/x86_64/bits/alltypes.h.sh
-+++ b/arch/x86_64/bits/alltypes.h.sh
-@@ -20,6 +20,7 @@ TYPEDEF unsigned long size_t;
- TYPEDEF long ssize_t;
- TYPEDEF long ptrdiff_t;
- TYPEDEF __builtin_va_list va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF int wchar_t;
diff --git a/toolchain/musl/patches-0.9.8/005-install_portability.patch b/toolchain/musl/patches-0.9.8/005-install_portability.patch
deleted file mode 100644
index 3e018c67e9..0000000000
--- a/toolchain/musl/patches-0.9.8/005-install_portability.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -116,16 +116,20 @@ tools/musl-gcc: config.mak
- chmod +x $@
-
- $(DESTDIR)$(bindir)/%: tools/%
-- install -D $< $@
-+ mkdir -p $(dir $@)
-+ install $< $@
-
- $(DESTDIR)$(libdir)/%.so: lib/%.so
-- install -D -m 755 $< $@
-+ mkdir -p $(dir $@)
-+ install -m 755 $< $@
-
- $(DESTDIR)$(libdir)/%: lib/%
-- install -D -m 644 $< $@
-+ mkdir -p $(dir $@)
-+ install -m 644 $< $@
-
- $(DESTDIR)$(includedir)/%: include/%
-- install -D -m 644 $< $@
-+ mkdir -p $(dir $@)
-+ install -m 644 $< $@
-
- $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(syslibdir)
- ln -sf $(libdir)/libc.so $@ || true