summaryrefslogtreecommitdiffstats
path: root/shared/opensource/spi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shared/opensource/spi/Makefile')
-rwxr-xr-xshared/opensource/spi/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/shared/opensource/spi/Makefile b/shared/opensource/spi/Makefile
new file mode 100755
index 0000000..b3eb2b1
--- /dev/null
+++ b/shared/opensource/spi/Makefile
@@ -0,0 +1,30 @@
+
+ifeq ($(CONFIG_MIPS_BRCM),y)
+
+ifeq ($(strip $(BRCM_CHIP)),6362)
+obj-y += \
+ bcmHsSpi.o
+else
+ifeq ($(strip $(BRCM_CHIP)),6816)
+obj-y += \
+ bcmHsSpi.o
+else
+ifeq ($(strip $(BRCM_CHIP)),6328)
+obj-y += \
+ bcmHsSpi.o
+endif
+endif
+endif
+
+ifneq ($(strip $(BRCM_CHIP)),6328)
+obj-y += \
+ bcmLegSpi.o
+endif
+
+obj-y += \
+ bcmSpiRes.o
+
+EXTRA_CFLAGS += -DCONFIG_BCM9$(BRCM_CHIP) -I$(INC_BRCMDRIVER_PUB_PATH)/$(BRCM_BOARD) -I$(INC_BRCMSHARED_PUB_PATH)/$(BRCM_BOARD)
+
+endif
+