aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/ipv6-support/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/network/ipv6/ipv6-support/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'package/network/ipv6/ipv6-support/.svn')
-rw-r--r--package/network/ipv6/ipv6-support/.svn/entries65
-rw-r--r--package/network/ipv6/ipv6-support/.svn/text-base/Makefile.svn-base41
2 files changed, 106 insertions, 0 deletions
diff --git a/package/network/ipv6/ipv6-support/.svn/entries b/package/network/ipv6/ipv6-support/.svn/entries
new file mode 100644
index 0000000..bf569ea
--- /dev/null
+++ b/package/network/ipv6/ipv6-support/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/network/ipv6/ipv6-support
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-01-23T08:15:09.884089Z
+35302
+cyrus
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:19.000000Z
+9718fb88ca6a0a8205862cb406c6eac4
+2013-01-23T08:15:09.884089Z
+35302
+cyrus
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+976
+
diff --git a/package/network/ipv6/ipv6-support/.svn/text-base/Makefile.svn-base b/package/network/ipv6/ipv6-support/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..5ad52f8
--- /dev/null
+++ b/package/network/ipv6/ipv6-support/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2010-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ipv6-support
+PKG_VERSION:=2013-01-23
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ipv6-support
+ SECTION:=ipv6
+ CATEGORY:=IPv6
+ DEPENDS:=+kmod-ipv6 +6relayd +odhcp6c +ip6tables
+ TITLE:=Basic IPv6-support for Customer Edge Routers
+ MAINTAINER:=Steven Barth <steven@midlink.org>
+ PKGARCH:=all
+endef
+
+define Package/ipv6-support/description
+This package provides basic IPv6 support including Router Discovery,
+DHCPv6 (client & server), prefix delegation and distribution.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/ipv6-support/install
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/network-enable-ipv6.defaults $(1)/etc/uci-defaults/10_network-enable-ipv6
+endef
+
+$(eval $(call BuildPackage,ipv6-support))