aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/maccalc/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/network/utils/maccalc/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'package/network/utils/maccalc/.svn')
-rw-r--r--package/network/utils/maccalc/.svn/entries65
-rw-r--r--package/network/utils/maccalc/.svn/prop-base/Makefile.svn-base5
-rw-r--r--package/network/utils/maccalc/.svn/text-base/Makefile.svn-base47
3 files changed, 117 insertions, 0 deletions
diff --git a/package/network/utils/maccalc/.svn/entries b/package/network/utils/maccalc/.svn/entries
new file mode 100644
index 0000000..52b6469
--- /dev/null
+++ b/package/network/utils/maccalc/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/network/utils/maccalc
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-10T12:32:29.935169Z
+33688
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+src
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:17.000000Z
+0af840bc74ddd953cc60c1692895a21a
+2011-08-15T18:55:51.371841Z
+28004
+juhosg
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+921
+
diff --git a/package/network/utils/maccalc/.svn/prop-base/Makefile.svn-base b/package/network/utils/maccalc/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/package/network/utils/maccalc/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/package/network/utils/maccalc/.svn/text-base/Makefile.svn-base b/package/network/utils/maccalc/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..09cdfc8
--- /dev/null
+++ b/package/network/utils/maccalc/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=maccalc
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/maccalc
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=MAC address calculation
+endef
+
+define Package/maccalc/description
+ This package contains a MAC address manipulation utility.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -Wall" \
+ LDFLAGS="$(TARGET_LDFLAGS)"
+endef
+
+define Package/maccalc/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/maccalc $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,maccalc))