aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/gpio-button-hotplug/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/system/gpio-button-hotplug/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'package/system/gpio-button-hotplug/.svn')
-rw-r--r--package/system/gpio-button-hotplug/.svn/entries65
-rw-r--r--package/system/gpio-button-hotplug/.svn/text-base/Makefile.svn-base44
2 files changed, 109 insertions, 0 deletions
diff --git a/package/system/gpio-button-hotplug/.svn/entries b/package/system/gpio-button-hotplug/.svn/entries
new file mode 100644
index 0000000..a9df471
--- /dev/null
+++ b/package/system/gpio-button-hotplug/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/system/gpio-button-hotplug
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-01-27T21:17:38.011676Z
+35335
+hauke
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+src
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:14.000000Z
+6b77e1a5554ca86e2c5c945032c59e54
+2012-10-17T22:45:58.668189Z
+33830
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+963
+
diff --git a/package/system/gpio-button-hotplug/.svn/text-base/Makefile.svn-base b/package/system/gpio-button-hotplug/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..adb9a45
--- /dev/null
+++ b/package/system/gpio-button-hotplug/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=gpio-button-hotplug
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/gpio-button-hotplug
+ SUBMENU:=Other modules
+ TITLE:=Simple GPIO Button Hotplug driver
+ FILES:=$(PKG_BUILD_DIR)/gpio-button-hotplug.ko
+ AUTOLOAD:=$(call AutoLoad,30,gpio-button-hotplug)
+ KCONFIG:=
+endef
+
+define KernelPackage/button-hotplug/description
+ Kernel module to generate GPIO button hotplug events
+endef
+
+MAKE_OPTS:= \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)"
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C "$(LINUX_DIR)" \
+ $(MAKE_OPTS) \
+ modules
+endef
+
+$(eval $(call KernelPackage,gpio-button-hotplug))