aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt/patches
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/quilt/patches
downloadtrunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.gz
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.bz2
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.zip
Diffstat (limited to 'tools/quilt/patches')
-rw-r--r--tools/quilt/patches/.svn/entries130
-rw-r--r--tools/quilt/patches/.svn/text-base/000-relocatable.patch.svn-base83
-rw-r--r--tools/quilt/patches/.svn/text-base/001-fix_compile.patch.svn-base18
-rw-r--r--tools/quilt/patches/.svn/text-base/100-patch_2.6.1_version.patch.svn-base15
-rw-r--r--tools/quilt/patches/000-relocatable.patch83
-rw-r--r--tools/quilt/patches/001-fix_compile.patch18
-rw-r--r--tools/quilt/patches/100-patch_2.6.1_version.patch15
7 files changed, 362 insertions, 0 deletions
diff --git a/tools/quilt/patches/.svn/entries b/tools/quilt/patches/.svn/entries
new file mode 100644
index 0000000..b4f6071
--- /dev/null
+++ b/tools/quilt/patches/.svn/entries
@@ -0,0 +1,130 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/quilt/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-01-20T17:54:43.742351Z
+29834
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+100-patch_2.6.1_version.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+ca50e35bc2dc96d5b519452a0f02a6da
+2011-05-02T12:53:32.333230Z
+26804
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+400
+
+000-relocatable.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+2a5688c53c1b380ca8f1ecc9a8ceafdc
+2012-01-20T17:54:43.742351Z
+29834
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2250
+
+001-fix_compile.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+ae06fdba612d596f3db5b155b4b77d71
+2012-01-20T17:11:37.203130Z
+29829
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+428
+
diff --git a/tools/quilt/patches/.svn/text-base/000-relocatable.patch.svn-base b/tools/quilt/patches/.svn/text-base/000-relocatable.patch.svn-base
new file mode 100644
index 0000000..f811023
--- /dev/null
+++ b/tools/quilt/patches/.svn/text-base/000-relocatable.patch.svn-base
@@ -0,0 +1,83 @@
+--- a/bin/quilt.in
++++ b/bin/quilt.in
+@@ -7,9 +7,15 @@
+ # See the COPYING and AUTHORS files for more details.
+
+ export TEXTDOMAIN=quilt
+-export TEXTDOMAINDIR=@LOCALEDIR@
+
+-: ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
++if test -n "$STAGING_DIR"; then
++ export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
++ : ${QUILT_DIR=$STAGING_DIR/../host/share/quilt} ${QUILT_LIB=$STAGING_DIR/../host/lib/quilt}
++else
++ export TEXTDOMAINDIR=@LOCALEDIR@
++ : ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
++fi
++
+ export QUILT_DIR QUILT_LIB
+
+ if [ -z "$QUILTRC" ]
+--- a/quilt/scripts/edmail.in
++++ b/quilt/scripts/edmail.in
+@@ -29,7 +29,7 @@ BEGIN {
+ }
+
+ setlocale(LC_MESSAGES, "");
+-bindtextdomain("quilt", "@LOCALEDIR@");
++bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
+ textdomain("quilt");
+
+ sub _($) {
+--- a/quilt/scripts/inspect.in
++++ b/quilt/scripts/inspect.in
+@@ -6,7 +6,11 @@
+ #
+ # See the COPYING and AUTHORS files for more details.
+
+-: ${QUILT_DIR=@QUILT_DIR@}
++if test -n "$STAGING_DIR"; then
++ : ${QUILT_DIR="$STAGING_DIR/../host/share/quilt"}
++else
++ : ${QUILT_DIR=@QUILT_DIR@}
++fi
+
+ if ! [ -r $QUILT_DIR/scripts/patchfns ]
+ then
+--- a/quilt/scripts/parse-patch.in
++++ b/quilt/scripts/parse-patch.in
+@@ -34,7 +34,7 @@ BEGIN {
+ }
+
+ setlocale(LC_MESSAGES, "");
+-bindtextdomain("quilt", "@LOCALEDIR@");
++bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
+ textdomain("quilt");
+
+ sub _($) {
+--- a/quilt/scripts/patchfns.in
++++ b/quilt/scripts/patchfns.in
+@@ -10,7 +10,11 @@
+ # See the COPYING and AUTHORS files for more details.
+
+ export TEXTDOMAIN=quilt
+-export TEXTDOMAINDIR=@LOCALEDIR@
++if [ -n "$STAGING_DIR" ]; then
++ export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
++else
++ export TEXTDOMAINDIR=@LOCALEDIR@
++fi
+
+ : ${LC_CTYPE:=$LANG}
+ : ${LC_MESSAGES:=$LANG}
+--- a/quilt/scripts/remove-trailing-ws.in
++++ b/quilt/scripts/remove-trailing-ws.in
+@@ -31,7 +31,7 @@ BEGIN {
+ }
+
+ setlocale(LC_MESSAGES, "");
+-bindtextdomain("quilt", "@LOCALEDIR@");
++bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
+ textdomain("quilt");
+
+ sub _($) {
diff --git a/tools/quilt/patches/.svn/text-base/001-fix_compile.patch.svn-base b/tools/quilt/patches/.svn/text-base/001-fix_compile.patch.svn-base
new file mode 100644
index 0000000..51a4f5e
--- /dev/null
+++ b/tools/quilt/patches/.svn/text-base/001-fix_compile.patch.svn-base
@@ -0,0 +1,18 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -273,13 +273,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+ lib/backup-files.o :: Makefile
+
+ configure : configure.ac aclocal.m4
+- autoconf
+- @echo "Please run ./configure"
+- @false
++ @touch $@
+
+ Makefile : Makefile.in configure
+- @echo "Please run ./configure"
+- @false
++ @touch $@
+
+ compat_leftover := $(filter-out $(COMPAT),$(shell $(FIND) compat -maxdepth 1 -type f -perm +111))
+
diff --git a/tools/quilt/patches/.svn/text-base/100-patch_2.6.1_version.patch.svn-base b/tools/quilt/patches/.svn/text-base/100-patch_2.6.1_version.patch.svn-base
new file mode 100644
index 0000000..1e9ed75
--- /dev/null
+++ b/tools/quilt/patches/.svn/text-base/100-patch_2.6.1_version.patch.svn-base
@@ -0,0 +1,15 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,11 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version
diff --git a/tools/quilt/patches/000-relocatable.patch b/tools/quilt/patches/000-relocatable.patch
new file mode 100644
index 0000000..f811023
--- /dev/null
+++ b/tools/quilt/patches/000-relocatable.patch
@@ -0,0 +1,83 @@
+--- a/bin/quilt.in
++++ b/bin/quilt.in
+@@ -7,9 +7,15 @@
+ # See the COPYING and AUTHORS files for more details.
+
+ export TEXTDOMAIN=quilt
+-export TEXTDOMAINDIR=@LOCALEDIR@
+
+-: ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
++if test -n "$STAGING_DIR"; then
++ export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
++ : ${QUILT_DIR=$STAGING_DIR/../host/share/quilt} ${QUILT_LIB=$STAGING_DIR/../host/lib/quilt}
++else
++ export TEXTDOMAINDIR=@LOCALEDIR@
++ : ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
++fi
++
+ export QUILT_DIR QUILT_LIB
+
+ if [ -z "$QUILTRC" ]
+--- a/quilt/scripts/edmail.in
++++ b/quilt/scripts/edmail.in
+@@ -29,7 +29,7 @@ BEGIN {
+ }
+
+ setlocale(LC_MESSAGES, "");
+-bindtextdomain("quilt", "@LOCALEDIR@");
++bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
+ textdomain("quilt");
+
+ sub _($) {
+--- a/quilt/scripts/inspect.in
++++ b/quilt/scripts/inspect.in
+@@ -6,7 +6,11 @@
+ #
+ # See the COPYING and AUTHORS files for more details.
+
+-: ${QUILT_DIR=@QUILT_DIR@}
++if test -n "$STAGING_DIR"; then
++ : ${QUILT_DIR="$STAGING_DIR/../host/share/quilt"}
++else
++ : ${QUILT_DIR=@QUILT_DIR@}
++fi
+
+ if ! [ -r $QUILT_DIR/scripts/patchfns ]
+ then
+--- a/quilt/scripts/parse-patch.in
++++ b/quilt/scripts/parse-patch.in
+@@ -34,7 +34,7 @@ BEGIN {
+ }
+
+ setlocale(LC_MESSAGES, "");
+-bindtextdomain("quilt", "@LOCALEDIR@");
++bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
+ textdomain("quilt");
+
+ sub _($) {
+--- a/quilt/scripts/patchfns.in
++++ b/quilt/scripts/patchfns.in
+@@ -10,7 +10,11 @@
+ # See the COPYING and AUTHORS files for more details.
+
+ export TEXTDOMAIN=quilt
+-export TEXTDOMAINDIR=@LOCALEDIR@
++if [ -n "$STAGING_DIR" ]; then
++ export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
++else
++ export TEXTDOMAINDIR=@LOCALEDIR@
++fi
+
+ : ${LC_CTYPE:=$LANG}
+ : ${LC_MESSAGES:=$LANG}
+--- a/quilt/scripts/remove-trailing-ws.in
++++ b/quilt/scripts/remove-trailing-ws.in
+@@ -31,7 +31,7 @@ BEGIN {
+ }
+
+ setlocale(LC_MESSAGES, "");
+-bindtextdomain("quilt", "@LOCALEDIR@");
++bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
+ textdomain("quilt");
+
+ sub _($) {
diff --git a/tools/quilt/patches/001-fix_compile.patch b/tools/quilt/patches/001-fix_compile.patch
new file mode 100644
index 0000000..51a4f5e
--- /dev/null
+++ b/tools/quilt/patches/001-fix_compile.patch
@@ -0,0 +1,18 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -273,13 +273,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+ lib/backup-files.o :: Makefile
+
+ configure : configure.ac aclocal.m4
+- autoconf
+- @echo "Please run ./configure"
+- @false
++ @touch $@
+
+ Makefile : Makefile.in configure
+- @echo "Please run ./configure"
+- @false
++ @touch $@
+
+ compat_leftover := $(filter-out $(COMPAT),$(shell $(FIND) compat -maxdepth 1 -type f -perm +111))
+
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
new file mode 100644
index 0000000..1e9ed75
--- /dev/null
+++ b/tools/quilt/patches/100-patch_2.6.1_version.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,11 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version