aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/.svn/text-base
diff options
context:
space:
mode:
Diffstat (limited to 'package/base-files/.svn/text-base')
-rw-r--r--package/base-files/.svn/text-base/Makefile.svn-base169
-rw-r--r--package/base-files/.svn/text-base/image-config.in.svn-base185
2 files changed, 354 insertions, 0 deletions
diff --git a/package/base-files/.svn/text-base/Makefile.svn-base b/package/base-files/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..90c2806
--- /dev/null
+++ b/package/base-files/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,169 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+# Copyright (C) 2010 Vertical Communications
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/version.mk
+
+PKG_NAME:=base-files
+PKG_RELEASE:=134
+
+PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
+PKG_BUILD_DEPENDS:=opkg/host
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
+
+include $(INCLUDE_DIR)/package.mk
+
+ifneq ($(DUMP),1)
+ TARGET:=-$(BOARD)
+ ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
+ TARGET:=$(TARGET)-$(PROFILE)
+ endif
+endif
+
+define Package/base-files
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=+netifd +libc +procd
+ TITLE:=Base filesystem for OpenWrt
+ URL:=http://openwrt.org/
+ VERSION:=$(PKG_RELEASE)-$(REVISION)
+endef
+
+define Package/base-files/conffiles
+/etc/hosts
+/etc/inittab
+/etc/group
+/etc/passwd
+/etc/shadow
+/etc/profile
+/etc/shells
+/etc/sysctl.conf
+/etc/rc.local
+/etc/sysupgrade.conf
+/etc/config/
+/etc/dropbear/
+/etc/crontabs/
+$(call $(TARGET)/conffiles)
+endef
+
+define Package/base-files/description
+ This package contains a base filesystem and system scripts for OpenWrt.
+endef
+
+define Package/base-files/config
+config PROCD_INIT
+ bool "Use procd as the init process"
+ default n
+endef
+
+ifeq ($(CONFIG_PROCD_INIT),)
+define InstallOldFiles
+ $(CP) ./files.old/* $(1)/
+endef
+endif
+
+ifneq ($(CONFIG_PREINITOPT),)
+define ImageConfigOptions
+ mkdir -p $(1)/lib/preinit
+ echo 'pi_suppress_stderr="$(CONFIG_TARGET_PREINIT_SUPPRESS_STDERR)"' >$(1)/lib/preinit/00_preinit.conf
+ echo 'fs_failsafe_wait_timeout=$(if $(CONFIG_TARGET_PREINIT_TIMEOUT),$(CONFIG_TARGET_PREINIT_TIMEOUT),2)' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_init_path=$(if $(CONFIG_TARGET_INIT_PATH),$(CONFIG_TARGET_INIT_PATH),"/bin:/sbin:/usr/bin:/usr/sbin")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_init_env=$(if $(CONFIG_TARGET_INIT_ENV),$(CONFIG_TARGET_INIT_ENV),"")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_init_cmd=$(if $(CONFIG_TARGET_INIT_CMD),$(CONFIG_TARGET_INIT_CMD),"/sbin/init")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_init_suppress_stderr="$(CONFIG_TARGET_INIT_SUPPRESS_STDERR)"' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_ifname=$(if $(CONFIG_TARGET_PREINIT_IFNAME),$(CONFIG_TARGET_PREINIT_IFNAME),"")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_ip=$(if $(CONFIG_TARGET_PREINIT_IP),$(CONFIG_TARGET_PREINIT_IP),"192.168.1.1")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_netmask=$(if $(CONFIG_TARGET_PREINIT_NETMASK),$(CONFIG_TARGET_PREINIT_NETMASK),"255.255.255.0")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_broadcast=$(if $(CONFIG_TARGET_PREINIT_BROADCAST),$(CONFIG_TARGET_PREINIT_BROADCAST),"192.168.1.255")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_preinit_net_messages="$(CONFIG_TARGET_PREINIT_SHOW_NETMSG)"' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_preinit_no_failsafe_netmsg="$(CONFIG_TARGET_PREINIT_SUPPRESS_FAILSAFE_NETMSG)"' >>$(1)/lib/preinit/00_preinit.conf
+endef
+endif
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Compile/Default
+
+endef
+Build/Compile = $(Build/Compile/Default)
+
+define Package/base-files/install
+ $(CP) ./files/* $(1)/
+ if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
+ $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
+ fi
+ $(call InstallOldFiles,$(1))
+ if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
+ $(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
+ fi
+ if [ -d $(PLATFORM_DIR)/base-files-$(PROFILE)/. ]; then \
+ $(CP) $(PLATFORM_DIR)/base-files-$(PROFILE)/* $(1)/; \
+ fi
+ if [ -d $(PLATFORM_DIR)/$(PROFILE)/base-files/. ]; then \
+ $(CP) $(PLATFORM_DIR)/$(PROFILE)/base-files/* $(1)/; \
+ fi
+ $(if $(filter-out $(PLATFORM_DIR),$(PLATFORM_SUBDIR)), \
+ if [ -d $(PLATFORM_SUBDIR)/base-files/. ]; then \
+ $(CP) $(PLATFORM_SUBDIR)/base-files/* $(1)/; \
+ fi; \
+ if [ -d $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/. ]; then \
+ $(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
+ fi; \
+ if [ -d $(PLATFORM_SUBDIR)/$(PROFILE)/base-files/. ]; then \
+ $(CP) $(PLATFORM_SUBDIR)/$(PROFILE)/base-files/* $(1)/; \
+ fi \
+ )
+
+ $(VERSION_SED) \
+ $(1)/etc/banner \
+ $(1)/etc/openwrt_version \
+ $(1)/etc/openwrt_release
+
+ mkdir -p $(1)/CONTROL
+ mkdir -p $(1)/dev
+ mkdir -p $(1)/etc/crontabs
+ mkdir -p $(1)/etc/rc.d
+ mkdir -p $(1)/overlay
+ mkdir -p $(1)/lib/firmware
+ $(if $(LIB_SUFFIX),-ln -s lib $(1)/lib$(LIB_SUFFIX))
+ mkdir -p $(1)/mnt
+ mkdir -p $(1)/proc
+ mkdir -p $(1)/tmp
+ mkdir -p $(1)/usr/lib
+ $(if $(LIB_SUFFIX),-ln -s lib $(1)/usr/lib$(LIB_SUFFIX))
+ mkdir -p $(1)/usr/bin
+ mkdir -p $(1)/sys
+ mkdir -p $(1)/www
+ mkdir -p $(1)/root
+ ln -sf /proc/mounts $(1)/etc/mtab
+ rm -f $(1)/var
+ ln -sf /tmp $(1)/var
+ mkdir -p $(1)/etc
+ ln -sf /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+
+ chmod 0600 $(1)/etc/shadow
+ chmod 1777 $(1)/tmp
+
+ $(call ImageConfigOptions,$(1))
+ $(call Package/base-files/install-target,$(1))
+ for conffile in $(1)/etc/config/*; do \
+ if [ -f "$$$$conffile" ]; then \
+ grep "$$$${conffile##$(1)}" $(1)/CONTROL/conffiles || \
+ echo "$$$${conffile##$(1)}" >> $(1)/CONTROL/conffiles; \
+ fi \
+ done
+endef
+
+ifneq ($(DUMP),1)
+ -include $(PLATFORM_DIR)/base-files.mk
+endif
+
+$(eval $(call BuildPackage,base-files))
diff --git a/package/base-files/.svn/text-base/image-config.in.svn-base b/package/base-files/.svn/text-base/image-config.in.svn-base
new file mode 100644
index 0000000..ac08c8d
--- /dev/null
+++ b/package/base-files/.svn/text-base/image-config.in.svn-base
@@ -0,0 +1,185 @@
+# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2010 Vertical Communications
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+menuconfig PREINITOPT
+ bool "Preinit configuration options" if IMAGEOPT
+ default n
+ help
+ These options are used to control the environment used to initialize
+ the system before running init (which typically mean /sbin/init which
+ switches to multiuser mode).
+
+config TARGET_PREINIT_SUPPRESS_STDERR
+ bool "Suppress stderr messages during preinit" if PREINITOPT
+ default y
+ help
+ Sends stderr to null during preinit. This is the default behaviour
+ in previous versions of OpenWRT. This also prevents init process
+ itself from displaying stderr, however processes launched by init
+ in multiuser through inittab will use the current terminal (e.g.
+ the ash shell launched by inittab will display stderr). That's
+ the same behaviour as seen in previous version of OpenWRT.
+
+config TARGET_PREINIT_TIMEOUT
+ int
+ prompt "Failsafe wait timeout" if PREINITOPT
+ default 2
+ help
+ How long to wait for failsafe mode to be entered before
+ continuing with a regular boot if failsafe not selected.
+
+config TARGET_PREINIT_SHOW_NETMSG
+ bool
+ prompt "Show all preinit network messages" if PREINITOPT
+ default n
+ help
+ Show preinit all network messages (via netmsg broadcast), not only
+ the message indicating to press reset to enter failsafe. Note that
+ if the architecture doesn't define an interface, and there is no
+ 'Preinit network interface' defined, then no messages will be
+ emitted, even if this is set.
+
+config TARGET_PREINIT_SUPPRESS_FAILSAFE_NETMSG
+ bool
+ prompt "Suppress network message indicating failsafe" if PREINITOPT
+ default n
+ help
+ If "Show all preinit network messages" above is not set, then
+ setting this option suppresses the only message that would be
+ emitted otherwise, name the network message to enter failsafe
+ (via netmsg).
+
+config TARGET_PREINIT_IFNAME
+ string
+ prompt "Preinit network interface" if PREINITOPT
+ default ""
+ help
+ Interface for sending preinit messages to network, and any other
+ default networking in failsafe or preinit. If empty
+ uses $ifname (if defined in /etc/preinit.arch).
+
+config TARGET_PREINIT_IP
+ string
+ prompt "IP address for preinit network messages" if PREINITOPT
+ default "192.168.1.1"
+ help
+ IP address used to configure interface for preinit network
+ messages, including failsafe messages
+
+config TARGET_PREINIT_NETMASK
+ string
+ prompt "Netmask for preinit network messages" if PREINITOPT
+ default "255.255.255.0"
+ help
+ Netmask used to configure interface for preinit network
+ messages, including failsafes messages
+
+config TARGET_PREINIT_BROADCAST
+ string
+ prompt "Broadcast address for preinit network messages" if PREINITOPT
+ default "192.168.1.255"
+ help
+ Broadcast address to which to send preinit network messages, as
+ as failsafe messages
+
+
+menuconfig INITOPT
+ bool "Init configuration options" if IMAGEOPT
+ default n
+ help
+ These option choose the command that will run as the 'init' command
+ (that is which is responsible for controlling the system once preinit
+ transfers control to it) as well as some options controlling its
+ behaviour. Normally init is /sbin/init.
+
+ config TARGET_INIT_PATH
+ string
+ prompt "PATH for regular boot" if INITOPT
+ default "/bin:/sbin:/usr/bin:/usr/sbin"
+ help
+ Default PATH used during normal operation
+
+ config TARGET_INIT_ENV
+ string
+ prompt "Environment variables to set when starting init (start with none)" if INITOPT
+ default ""
+ help
+ Should be a space seperated list of variable assignments. These
+ variables will be present in the environment. Spaces may not be
+ present (including through expansion) even in a quoted string
+ (env doesn't understanding quoting).
+
+ config TARGET_INIT_CMD
+ string
+ prompt "Init command" if INITOPT
+ default "/sbin/init"
+ help
+ The executable to run as the init process. Is 'exec'd by
+ preinit (which is the init that the kernel launches on boot).
+
+ config TARGET_INIT_SUPPRESS_STDERR
+ bool
+ prompt "Suppress stderr messages of init" if INITOPT
+ default y
+ help
+ Prevents showing stderr messages for init command if not already
+ suppressed during preinit. This is the default behaviour in
+ previous versions of OpenWRT. Removing this does nothing if
+ stderr is suppressed during preinit (which is the default).
+
+
+menuconfig VERSIONOPT
+ bool "Version configuration options" if IMAGEOPT
+ default n
+ help
+ These options allow to override the version information embedded in
+ the /etc/openwrt_version, /etc/openwrt_release, /etc/banner and
+ /etc/opkg.conf files. Usually there is no need to set these, but
+ they're useful for release builds or custom OpenWrt redistributions
+ that should carry custom version tags.
+
+ config VERSION_DIST
+ string
+ prompt "Release distribution" if VERSIONOPT
+ default "OpenWrt" if VERSIONOPT
+ help
+ This is the name of the release distribution.
+ If unspecified, it defaults to OpenWrt.
+
+ config VERSION_NICK
+ string
+ prompt "Release version nickname" if VERSIONOPT
+ help
+ This is the release codename embedded in the image.
+ If unspecified, it defaults to the name of source branch.
+
+ config VERSION_NUMBER
+ string
+ prompt "Release version number" if VERSIONOPT
+ help
+ This is the release version number embedded in the image.
+ If unspecified, it defaults to the svn or git-svn revision
+ of the build tree.
+
+ config VERSION_REPO
+ string
+ prompt "Release repository" if VERSIONOPT
+ default "http://downloads.openwrt.org/snapshots/trunk/%T/packages" if VERSIONOPT
+ help
+ This is the repository address embedded in the image, it defaults
+ to the trunk snapshot repo; the url may contain the following placeholders:
+ %R .. Revision number
+ %V .. Release version or revision number, uppercase
+ %v .. Release version or revision number, lowercase
+ %C .. Release version or "Bleeding Edge", uppercase
+ %c .. Release version or "bleeding_edge", lowercase
+ %N .. Release name, uppercase
+ %n .. Release name, lowercase
+ %D .. Distribution name or "OpenWrt", uppercase
+ %d .. Distribution name or "openwrt", lowercase
+ %T .. Target name
+ %S .. Target/Subtarget name