aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/rbcfg/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/rbcfg/.svn')
-rw-r--r--package/boot/rbcfg/.svn/entries65
-rw-r--r--package/boot/rbcfg/.svn/prop-base/Makefile.svn-base5
-rw-r--r--package/boot/rbcfg/.svn/text-base/Makefile.svn-base49
3 files changed, 119 insertions, 0 deletions
diff --git a/package/boot/rbcfg/.svn/entries b/package/boot/rbcfg/.svn/entries
new file mode 100644
index 0000000..a16907b
--- /dev/null
+++ b/package/boot/rbcfg/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/boot/rbcfg
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-17T21:53:23.143554Z
+33824
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+src
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:21.000000Z
+54ebd1734c602f5d5c63ed6b37cd830c
+2012-10-17T21:53:23.143554Z
+33824
+blogic
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1009
+
diff --git a/package/boot/rbcfg/.svn/prop-base/Makefile.svn-base b/package/boot/rbcfg/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/package/boot/rbcfg/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/package/boot/rbcfg/.svn/text-base/Makefile.svn-base b/package/boot/rbcfg/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..51fefd5
--- /dev/null
+++ b/package/boot/rbcfg/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rbcfg
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/rbcfg
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=RouterBOOT configuration tool
+ DEPENDS:=@TARGET_ar71xx
+endef
+
+define Package/rbcfg/description
+ This package contains an utility to manipulate RouterBOOT configuration on the
+ MikroTIK RB-4XX devices.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -Wall" \
+ LDFLAGS="$(TARGET_LDFLAGS)"
+endef
+
+define Package/rbcfg/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/rbcfg $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,rbcfg))