aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/patches/2.15/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/eglibc/patches/2.15/.svn')
-rw-r--r--toolchain/eglibc/patches/2.15/.svn/entries198
-rw-r--r--toolchain/eglibc/patches/2.15/.svn/text-base/001-fix_autoconf_macro.patch.svn-base48
-rw-r--r--toolchain/eglibc/patches/2.15/.svn/text-base/100-fix_cross_rpcgen.patch.svn-base71
-rw-r--r--toolchain/eglibc/patches/2.15/.svn/text-base/110-fix_cross_zic.patch.svn-base27
-rw-r--r--toolchain/eglibc/patches/2.15/.svn/text-base/120-use_host_cflags.patch.svn-base22
-rw-r--r--toolchain/eglibc/patches/2.15/.svn/text-base/200-add-dl-search-paths.patch.svn-base14
6 files changed, 380 insertions, 0 deletions
diff --git a/toolchain/eglibc/patches/2.15/.svn/entries b/toolchain/eglibc/patches/2.15/.svn/entries
new file mode 100644
index 0000000..98a3bf7
--- /dev/null
+++ b/toolchain/eglibc/patches/2.15/.svn/entries
@@ -0,0 +1,198 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/eglibc/patches/2.15
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-31T00:24:00.834736Z
+34026
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+001-fix_autoconf_macro.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+c09a6b07a644207f59c3a1a944cd4c67
+2012-06-07T12:24:25.679910Z
+32101
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1539
+
+110-fix_cross_zic.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+2434691b4892a595eddbdebe794a4d79
+2012-06-07T12:24:25.679910Z
+32101
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+708
+
+200-add-dl-search-paths.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+4257f0c32830da279484205acedf96f6
+2012-06-07T12:24:25.679910Z
+32101
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+367
+
+120-use_host_cflags.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+48a5b72a8700222dec9127b76f503d4f
+2012-10-31T00:24:00.834736Z
+34026
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+885
+
+100-fix_cross_rpcgen.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+7a4618804cc8cf88daff0246a4f791bd
+2012-06-07T12:24:25.679910Z
+32101
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2090
+
diff --git a/toolchain/eglibc/patches/2.15/.svn/text-base/001-fix_autoconf_macro.patch.svn-base b/toolchain/eglibc/patches/2.15/.svn/text-base/001-fix_autoconf_macro.patch.svn-base
new file mode 100644
index 0000000..55b26c7
--- /dev/null
+++ b/toolchain/eglibc/patches/2.15/.svn/text-base/001-fix_autoconf_macro.patch.svn-base
@@ -0,0 +1,48 @@
+--- a/libc/aclocal.m4
++++ b/libc/aclocal.m4
+@@ -88,6 +88,12 @@
+ fi
+ rm -fr contest*])
+
++dnl Test a compiler option or options with an empty input file.
++dnl LIBC_TRY_CC_OPTION([options], [action-if-true], [action-if-false])
++AC_DEFUN([LIBC_TRY_CC_OPTION],
++[AS_IF([AC_TRY_COMMAND([${CC-cc} $1 -xc /dev/null -S -o /dev/null])],
++ [$2], [$3])])
++
+ AC_DEFUN([LIBC_PROG_BINUTILS],
+ [# Was a --with-binutils option given?
+ if test -n "$path_binutils"; then
+--- a/libc/configure
++++ b/libc/configure
+@@ -7404,7 +7404,14 @@
+ else
+ libc_cv_cc_nofma=
+ for opt in -ffp-contract=off -mno-fused-madd; do
+- LIBC_TRY_CC_OPTION($opt, libc_cv_cc_nofma=$opt; break)
++ if { ac_try='${CC-cc} $opt -xc /dev/null -S -o /dev/null'
++ { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; }; then :
++ libc_cv_cc_nofma=$opt; break
++fi
+ done
+ fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_cc_nofma" >&5
+--- a/libc/configure.in
++++ b/libc/configure.in
+@@ -2238,10 +2238,9 @@
+ libc_cv_cc_submachine, [dnl
+ libc_cv_cc_submachine=no
+ for opt in "-march=$submachine" "-mcpu=$submachine"; do
+- if AC_TRY_COMMAND([${CC-cc} $opt -xc /dev/null -S -o /dev/null]); then
++ LIBC_TRY_CC_OPTION([$opt], [
+ libc_cv_cc_submachine="$opt"
+- break
+- fi
++ break], [])
+ done])
+ if test "x$libc_cv_cc_submachine" = xno; then
+ AC_MSG_ERROR([${CC-cc} does not support $submachine])
diff --git a/toolchain/eglibc/patches/2.15/.svn/text-base/100-fix_cross_rpcgen.patch.svn-base b/toolchain/eglibc/patches/2.15/.svn/text-base/100-fix_cross_rpcgen.patch.svn-base
new file mode 100644
index 0000000..8fe5cf3
--- /dev/null
+++ b/toolchain/eglibc/patches/2.15/.svn/text-base/100-fix_cross_rpcgen.patch.svn-base
@@ -0,0 +1,71 @@
+--- a/libc/sunrpc/proto.h
++++ b/libc/sunrpc/proto.h
+@@ -56,12 +56,14 @@ void add_type(int len, const char *type)
+ $build's C library and $host's GLIBC. */
+ #ifdef _CROSS_RPCGEN_
+
++#undef stpcpy
++
+ /* Rather then defining _GNU_SOURCE before including $build's <string.h>
+ we just declare stpcpy here. */
+ extern char *stpcpy (char *, const char *);
+
+-/* Use $build's i18n support as we can't use $host's. */
+-#define _(X) (gettext (X))
++/* Do not use i18n support */
++#define _(X) (X)
+
+ /* rpcgen sources check for __GNU_LIBRARY__ to tweak for GLIBC code
+ that rpcgen generates. The proper fix would be to rename all those checks
+--- a/libc/sunrpc/rpc/types.h
++++ b/libc/sunrpc/rpc/types.h
+@@ -70,18 +70,23 @@ typedef unsigned long rpcport_t;
+ #endif
+
+ #ifndef __u_char_defined
+-typedef __u_char u_char;
+-typedef __u_short u_short;
+-typedef __u_int u_int;
+-typedef __u_long u_long;
+-typedef __quad_t quad_t;
+-typedef __u_quad_t u_quad_t;
+-typedef __fsid_t fsid_t;
++typedef unsigned char u_char;
++typedef unsigned short u_short;
++typedef unsigned int u_int;
++typedef unsigned long u_long;
++#if __WORDSIZE == 64
++typedef long int quad_t;
++typedef unsigned long int u_quad_t;
++#elif defined __GLIBC_HAVE_LONG_LONG
++typedef long long int quad_t;
++typedef unsigned long long int u_quad_t;
++#endif
++typedef u_quad_t fsid_t;
+ # define __u_char_defined
+ #endif
+-#ifndef __daddr_t_defined
+-typedef __daddr_t daddr_t;
+-typedef __caddr_t caddr_t;
++#if !defined(__daddr_t_defined) && defined(linux)
++typedef long int daddr_t;
++typedef char *caddr_t;
+ # define __daddr_t_defined
+ #endif
+
+--- a/libc/sunrpc/rpc_main.c
++++ b/libc/sunrpc/rpc_main.c
+@@ -997,9 +997,10 @@ mkfile_output (struct commandline *cmd)
+ abort ();
+ temp = rindex (cmd->infile, '.');
+ cp = stpcpy (mkfilename, "Makefile.");
+- if (temp != NULL)
+- *((char *) stpncpy (cp, cmd->infile, temp - cmd->infile)) = '\0';
+- else
++ if (temp != NULL) {
++ strncpy(cp, cmd->infile, temp - cmd->infile);
++ cp[temp - cmd->infile - 1] = 0;
++ } else
+ stpcpy (cp, cmd->infile);
+
+ }
diff --git a/toolchain/eglibc/patches/2.15/.svn/text-base/110-fix_cross_zic.patch.svn-base b/toolchain/eglibc/patches/2.15/.svn/text-base/110-fix_cross_zic.patch.svn-base
new file mode 100644
index 0000000..221eb28
--- /dev/null
+++ b/toolchain/eglibc/patches/2.15/.svn/text-base/110-fix_cross_zic.patch.svn-base
@@ -0,0 +1,27 @@
+--- a/libc/timezone/zic.c
++++ b/libc/timezone/zic.c
+@@ -8,6 +8,8 @@ static char elsieid[] = "@(#)zic.c 8.19"
+ #ifdef CROSS_ZIC
+ #define REPORT_BUGS_TO ""
+ #define PKGVERSION ""
++#undef _
++#define _(X) (X)
+ #else
+ #include "config.h"
+ #endif
+@@ -490,6 +492,7 @@ char * argv[];
+ #ifdef unix
+ (void) umask(umask(S_IWGRP | S_IWOTH) | (S_IWGRP | S_IWOTH));
+ #endif /* defined unix */
++#ifndef CROSS_ZIC
+ #if HAVE_GETTEXT
+ (void) setlocale(LC_ALL, "");
+ #ifdef TZ_DOMAINDIR
+@@ -497,6 +500,7 @@ char * argv[];
+ #endif /* defined TEXTDOMAINDIR */
+ (void) textdomain(TZ_DOMAIN);
+ #endif /* HAVE_GETTEXT */
++#endif
+ progname = argv[0];
+ if (TYPE_BIT(zic_t) < 64) {
+ (void) fprintf(stderr, "%s: %s\n", progname,
diff --git a/toolchain/eglibc/patches/2.15/.svn/text-base/120-use_host_cflags.patch.svn-base b/toolchain/eglibc/patches/2.15/.svn/text-base/120-use_host_cflags.patch.svn-base
new file mode 100644
index 0000000..4c58fb4
--- /dev/null
+++ b/toolchain/eglibc/patches/2.15/.svn/text-base/120-use_host_cflags.patch.svn-base
@@ -0,0 +1,22 @@
+--- a/libc/sunrpc/Makefile
++++ b/libc/sunrpc/Makefile
+@@ -175,7 +175,7 @@ $(objpfx)rpcgen: $(addprefix $(objpfx),$
+ $(+link)
+
+ $(addprefix $(objpfx)cross-,$(rpcgen-objs)): $(objpfx)cross-%.o: %.c
+- gcc $< -c -D_RPC_THREAD_SAFE_ -D_CROSS_RPCGEN_ \
++ gcc $< -c -D_RPC_THREAD_SAFE_ -D_CROSS_RPCGEN_ $(HOST_CFLAGS) \
+ $(OUTPUT_OPTION) $(compile-mkdep-flags)
+
+ $(objpfx)cross-rpcgen: $(addprefix $(objpfx)cross-,$(rpcgen-objs))
+--- a/libc/timezone/Makefile
++++ b/libc/timezone/Makefile
+@@ -182,7 +182,7 @@ $(objpfx)zic: $(addprefix $(objpfx), $(z
+
+ $(addprefix $(objpfx)cross-,$(zic-objs)): $(objpfx)cross-%.o: %.c
+ gcc $< -c $(OUTPUT_OPTION) $(CFLAGS-$*.c) $(CPPFLAGS-$*) \
+- -DCROSS_ZIC $(compile-mkdep-flags)
++ -DCROSS_ZIC $(HOST_CFLAGS) $(compile-mkdep-flags)
+
+ $(objpfx)cross-zic: $(addprefix $(objpfx)cross-,$(zic-objs))
+ gcc $(addprefix $(objpfx)cross-,$(zic-objs)) -o $@
diff --git a/toolchain/eglibc/patches/2.15/.svn/text-base/200-add-dl-search-paths.patch.svn-base b/toolchain/eglibc/patches/2.15/.svn/text-base/200-add-dl-search-paths.patch.svn-base
new file mode 100644
index 0000000..70e7e60
--- /dev/null
+++ b/toolchain/eglibc/patches/2.15/.svn/text-base/200-add-dl-search-paths.patch.svn-base
@@ -0,0 +1,14 @@
+add /usr/lib to default search path for the dynamic linker
+
+--- a/libc/Makeconfig
++++ b/libc/Makeconfig
+@@ -539,6 +539,9 @@
+ default-rpath = $(libdir)
+ endif
+
++# Add /usr/lib to default search path for the dynamic linker
++user-defined-trusted-dirs := /usr/lib
++
+ ifndef link-extra-libs
+ link-extra-libs = $(LDLIBS-$(@F))
+ link-extra-libs-static = $(link-extra-libs)