aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/headers/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/uClibc/headers/.svn')
-rw-r--r--toolchain/uClibc/headers/.svn/entries62
-rw-r--r--toolchain/uClibc/headers/.svn/text-base/Makefile.svn-base26
2 files changed, 88 insertions, 0 deletions
diff --git a/toolchain/uClibc/headers/.svn/entries b/toolchain/uClibc/headers/.svn/entries
new file mode 100644
index 0000000..1269873
--- /dev/null
+++ b/toolchain/uClibc/headers/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/uClibc/headers
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-06-30T21:44:05.716512Z
+32557
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+d47d7569f934a0944aeee8041895f791
+2012-06-30T21:44:05.716512Z
+32557
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+557
+
diff --git a/toolchain/uClibc/headers/.svn/text-base/Makefile.svn-base b/toolchain/uClibc/headers/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..67a2d95
--- /dev/null
+++ b/toolchain/uClibc/headers/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,26 @@
+PATH_PREFIX:=..
+
+include ../common.mk
+
+HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.headers_built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_headers_installed
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
+ PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
+ DEVEL_PREFIX=/ \
+ RUNTIME_PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
+ HOSTCC="$(HOSTCC)" \
+ CC="$(TARGET_CC)" \
+ CPU_CFLAGS="$(TARGET_CFLAGS)" \
+ ARCH="$(CONFIG_ARCH)" \
+ pregen \
+ install_headers
+endef
+
+$(eval $(call HostBuild))
+