aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison/patches
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison/patches')
-rw-r--r--tools/bison/patches/.svn/entries130
-rw-r--r--tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base20
-rw-r--r--tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base15
-rw-r--r--tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base16
-rw-r--r--tools/bison/patches/000-relocatable.patch20
-rw-r--r--tools/bison/patches/010-intl-stub-compat.patch15
-rw-r--r--tools/bison/patches/100-fix-gets-removal.patch16
7 files changed, 232 insertions, 0 deletions
diff --git a/tools/bison/patches/.svn/entries b/tools/bison/patches/.svn/entries
new file mode 100644
index 0000000..e08b2b2
--- /dev/null
+++ b/tools/bison/patches/.svn/entries
@@ -0,0 +1,130 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/bison/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-28T00:52:34.934626Z
+35827
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+100-fix-gets-removal.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+4224463f2de2d892d2d0af6a95181372
+2013-02-28T00:52:34.934626Z
+35827
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+468
+
+000-relocatable.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+ee005dbe2048ad7e4ab23c2600d69b3d
+2013-02-28T00:52:34.934626Z
+35827
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+649
+
+010-intl-stub-compat.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+bf0482e5801ab1ed0c397e3de91c6621
+2013-02-28T00:52:34.934626Z
+35827
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+440
+
diff --git a/tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base b/tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base
new file mode 100644
index 0000000..47c0ae8
--- /dev/null
+++ b/tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base
@@ -0,0 +1,20 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -81,6 +81,7 @@ MOSTLYCLEANFILES = yacc
+
+ yacc:
+ $(AM_V_GEN)echo '#! /bin/sh' >$@
++ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ $(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ $(AM_V_at)chmod a+x $@
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1919,6 +1919,7 @@ uninstall-am: uninstall-binPROGRAMS unin
+
+ yacc:
+ $(AM_V_GEN)echo '#! /bin/sh' >$@
++ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ $(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ $(AM_V_at)chmod a+x $@
+
diff --git a/tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base b/tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base
new file mode 100644
index 0000000..d2dfcad
--- /dev/null
+++ b/tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base
@@ -0,0 +1,15 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -60,9 +60,9 @@ main (int argc, char *argv[])
+ {
+ set_program_name (argv[0]);
+ setlocale (LC_ALL, "");
+- (void) bindtextdomain (PACKAGE, LOCALEDIR);
+- (void) bindtextdomain ("bison-runtime", LOCALEDIR);
+- (void) textdomain (PACKAGE);
++ bindtextdomain (PACKAGE, LOCALEDIR);
++ bindtextdomain ("bison-runtime", LOCALEDIR);
++ textdomain (PACKAGE);
+
+ {
+ char const *cp = getenv ("LC_CTYPE");
diff --git a/tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base b/tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base
new file mode 100644
index 0000000..169bfd6
--- /dev/null
+++ b/tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base
@@ -0,0 +1,16 @@
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -704,13 +704,6 @@ _GL_WARN_ON_USE (getline, "getline is un
+ # endif
+ #endif
+
+-/* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning; besides, C11
+- removed it. */
+-#undef gets
+-#if HAVE_RAW_DECL_GETS
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-#endif
+
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
diff --git a/tools/bison/patches/000-relocatable.patch b/tools/bison/patches/000-relocatable.patch
new file mode 100644
index 0000000..47c0ae8
--- /dev/null
+++ b/tools/bison/patches/000-relocatable.patch
@@ -0,0 +1,20 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -81,6 +81,7 @@ MOSTLYCLEANFILES = yacc
+
+ yacc:
+ $(AM_V_GEN)echo '#! /bin/sh' >$@
++ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ $(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ $(AM_V_at)chmod a+x $@
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1919,6 +1919,7 @@ uninstall-am: uninstall-binPROGRAMS unin
+
+ yacc:
+ $(AM_V_GEN)echo '#! /bin/sh' >$@
++ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ $(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ $(AM_V_at)chmod a+x $@
+
diff --git a/tools/bison/patches/010-intl-stub-compat.patch b/tools/bison/patches/010-intl-stub-compat.patch
new file mode 100644
index 0000000..d2dfcad
--- /dev/null
+++ b/tools/bison/patches/010-intl-stub-compat.patch
@@ -0,0 +1,15 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -60,9 +60,9 @@ main (int argc, char *argv[])
+ {
+ set_program_name (argv[0]);
+ setlocale (LC_ALL, "");
+- (void) bindtextdomain (PACKAGE, LOCALEDIR);
+- (void) bindtextdomain ("bison-runtime", LOCALEDIR);
+- (void) textdomain (PACKAGE);
++ bindtextdomain (PACKAGE, LOCALEDIR);
++ bindtextdomain ("bison-runtime", LOCALEDIR);
++ textdomain (PACKAGE);
+
+ {
+ char const *cp = getenv ("LC_CTYPE");
diff --git a/tools/bison/patches/100-fix-gets-removal.patch b/tools/bison/patches/100-fix-gets-removal.patch
new file mode 100644
index 0000000..169bfd6
--- /dev/null
+++ b/tools/bison/patches/100-fix-gets-removal.patch
@@ -0,0 +1,16 @@
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -704,13 +704,6 @@ _GL_WARN_ON_USE (getline, "getline is un
+ # endif
+ #endif
+
+-/* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning; besides, C11
+- removed it. */
+-#undef gets
+-#if HAVE_RAW_DECL_GETS
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-#endif
+
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@