aboutsummaryrefslogtreecommitdiffstats
path: root/tools/padjffs2/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'tools/padjffs2/.svn')
-rw-r--r--tools/padjffs2/.svn/entries65
-rw-r--r--tools/padjffs2/.svn/prop-base/Makefile.svn-base5
-rw-r--r--tools/padjffs2/.svn/text-base/Makefile.svn-base36
3 files changed, 106 insertions, 0 deletions
diff --git a/tools/padjffs2/.svn/entries b/tools/padjffs2/.svn/entries
new file mode 100644
index 0000000..25a13a8
--- /dev/null
+++ b/tools/padjffs2/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/padjffs2
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-08-12T13:27:49.032927Z
+33148
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+src
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+ce1929b3e02961adc212287f3fad4807
+2012-08-12T13:27:49.032927Z
+33148
+jow
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+696
+
diff --git a/tools/padjffs2/.svn/prop-base/Makefile.svn-base b/tools/padjffs2/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/tools/padjffs2/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/tools/padjffs2/.svn/text-base/Makefile.svn-base b/tools/padjffs2/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..4535735
--- /dev/null
+++ b/tools/padjffs2/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=padjffs2
+PKG_VERSION:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Prepare
+ mkdir -p $(HOST_BUILD_DIR)
+ $(CP) ./src/* $(HOST_BUILD_DIR)/
+ find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
+endef
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="$(HOST_STATIC_LINKING)"
+endef
+
+define Host/Configure
+endef
+
+define Host/Install
+ $(CP) $(HOST_BUILD_DIR)/padjffs2 $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/padjffs2
+endef
+
+$(eval $(call HostBuild))