aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2019-03-26 22:09:24 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-04-06 19:14:06 +0200
commit007e947976132cb6a39befcf8883beef69e7bee9 (patch)
treec151bf2aa8c82de74f36e8be9fe9ca7d74c1a700
parent46dc4e206d24a88bba103e28632b28ec9d9ec751 (diff)
downloadupstream-007e947976132cb6a39befcf8883beef69e7bee9.tar.gz
upstream-007e947976132cb6a39befcf8883beef69e7bee9.tar.bz2
upstream-007e947976132cb6a39befcf8883beef69e7bee9.zip
fconfig: cleanup Makefile
We do not need to define an empty Build/Configure since the default checks for existing ./configure and does nothing in case nothing is found. Similar for Build/Compile: we can remove the definition when we only call the default. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--package/boot/fconfig/Makefile7
1 files changed, 0 insertions, 7 deletions
diff --git a/package/boot/fconfig/Makefile b/package/boot/fconfig/Makefile
index d82fa8db90..9b806fe97c 100644
--- a/package/boot/fconfig/Makefile
+++ b/package/boot/fconfig/Makefile
@@ -30,13 +30,6 @@ define Package/fconfig/description
displays and (if writable) also edits the RedBoot configuration.
endef
-define Build/Configure
-endef
-
-define Build/Compile
- $(call Build/Compile/Default)
-endef
-
define Package/fconfig/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/