aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-04-17 13:43:06 +0200
committerFelix Fietkau <nbd@nbd.name>2018-04-17 13:46:18 +0200
commit00dcccc74cf893dc453c715c74c342f88a67c6c0 (patch)
treea62a1660dbfc6ab53ed9b3fb9b81d943e76fcf2c
parent14c78a7dfc27a0f6228a569f407b48a8f020de8d (diff)
downloadupstream-00dcccc74cf893dc453c715c74c342f88a67c6c0.tar.gz
upstream-00dcccc74cf893dc453c715c74c342f88a67c6c0.tar.bz2
upstream-00dcccc74cf893dc453c715c74c342f88a67c6c0.zip
mediatek: fix target FPU settings
This reverts commit 5555545494c876adedf4f0038db49c1d85527e78. The target supports both NEON and VFPv4, but for this to work properly, a few more changes are needed: - enable NEON support in the kernel config - add the fpu feature flag to the makefile Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--target/linux/mediatek/32/target.mk1
-rw-r--r--target/linux/mediatek/Makefile2
-rw-r--r--target/linux/mediatek/config-4.142
3 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/mediatek/32/target.mk b/target/linux/mediatek/32/target.mk
index 146ad95ffc..0a444c2758 100644
--- a/target/linux/mediatek/32/target.mk
+++ b/target/linux/mediatek/32/target.mk
@@ -5,6 +5,7 @@
SUBTARGET:=32
BOARDNAME:=32bit
CPU_TYPE:=cortex-a7
+CPU_SUBTYPE:=neon-vfpv4
define Target/Description
Build firmware images for MediaTek 32bit ARM based boards.
diff --git a/target/linux/mediatek/Makefile b/target/linux/mediatek/Makefile
index fb294ad8fb..415fe94504 100644
--- a/target/linux/mediatek/Makefile
+++ b/target/linux/mediatek/Makefile
@@ -6,7 +6,7 @@ ARCH:=arm
BOARD:=mediatek
BOARDNAME:=MediaTek Ralink ARM
SUBTARGETS:=32
-FEATURES:=squashfs nand ubifs
+FEATURES:=squashfs nand ubifs fpu
MAINTAINER:=John Crispin <john@phrozen.org>
KERNEL_PATCHVER:=4.14
diff --git a/target/linux/mediatek/config-4.14 b/target/linux/mediatek/config-4.14
index 40977aab73..88165045c8 100644
--- a/target/linux/mediatek/config-4.14
+++ b/target/linux/mediatek/config-4.14
@@ -334,7 +334,7 @@ CONFIG_MTK_TIMER=y
CONFIG_MULTI_IRQ_HANDLER=y
CONFIG_MUTEX_SPIN_ON_OWNER=y
CONFIG_NEED_DMA_MAP_STATE=y
-# CONFIG_NEON is not set
+CONFIG_NEON=y
CONFIG_NET_DSA=y
CONFIG_NET_DSA_MT7530=y
CONFIG_NET_DSA_TAG_MTK=y